Вход | Регистрация
 

БСП, подсистема ВариантыОтчетов

БСП, подсистема ВариантыОтчетов
Я
   Momus
 
08.06.20 - 19:18
Помогите разобраться с подсистемой. Есть внешний отчет, некоторые команды я хочу переопределить (например, выбор периода). Прочитал на ИТС описание и комментарии в модулях понял, что нужно использовать 4 процедуры:

Процедура ОпределитьНастройкиФормы(Форма, КлючВарианта, Настройки) Экспорт    
    Настройки.События.ПриОпределенииПараметровВыбора = Истина;
КонецПроцедуры

Процедура ПриОпределенииПараметровВыбора(Форма, СвойстваНастройки) Экспорт
    // Обработка события.
КонецПроцедуры

Процедура ПриНажатииКнопкиВыбораПериода(ФормаОтчета, Период, СтандартнаяОбработка, ОбработчикРезультата) Экспорт
    
КонецПроцедуры

Не могу понять как перейти от второй к первой. С созданием своей команды все понятно, а как переопределить стандартную - хз.
   Momus
 
1 - 08.06.20 - 19:22
Это же не для глобального переопределения служит (надеюсь не только для)?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.