Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не отрабатывает в клиент-серверной базе код

Не отрабатывает в клиент-серверной базе код
Я
   vladok00777
 
08.06.20 - 17:53
Добрый день, подскажите, пожалуйста! В модуле формы имею такой код для проставления подразделений в табличной части:

&НаКлиенте
Процедура ЗаполнитьТаблицуЗавершение(РезультатВопроса, ДополнительныеПараметры) Экспорт
    
    СписокТаблиц = ДополнительныеПараметры.СписокТаблиц;
    
    Ответ = РезультатВопроса;
    Если Ответ = КодВозвратаДиалога.Нет Тогда
        Возврат;
    КонецЕсли;
    
    ЗаполнитьТаблицуФрагмент(СписокТаблиц);
    ЗаполнитьПодразделение();
КонецПроцедуры


&НаСервере
Процедура ЗаполнитьПодразделение()
    Для Каждого Стр Из Объект.НачисленнаяЗарплатаИВзносы Цикл
        Если ТипЗнч(Стр.СпособОтраженияЗарплатыВБухучете.АналитикаРасходов) = Тип("СправочникСсылка.СтруктураПредприятия") Тогда
        Стр.ПодразделениеПредприятия = Стр.СпособОтраженияЗарплатыВБухучете.АналитикаРасходов;    
        КонецЕсли;    
    КонецЦикла;
КонецПроцедуры

Проблема в том, что в файловой базе отрабатывает, а в клиент-серверной почему-то нет, отладки на сервере нет (включить нет возможности). Никаких ошибок не выдает..
   mikecool
 
1 - 08.06.20 - 17:57
кеш
   Ёпрст
 
2 - 08.06.20 - 18:02
(0) обнови строки
   vfire1000
 
3 - 08.06.20 - 19:28
1. Оберени в попытку и выводи сообщение об ошибке
2. ЗаполнитьТаблицуФрагмент - тут что?
   vladok00777
 
4 - 08.06.20 - 19:32
(3) ЗаполнитьТаблицуФрагмент типовая процедура, заполняет табличную часть документа
   vladok00777
 
5 - 08.06.20 - 19:33
(3) там нет ошибки никакой, все отрабатывает, но поля в табличной части документа как были, так и есть. В файловой базе все норм
   Сергиус
 
6 - 08.06.20 - 21:31
(0)Вставь перед строкой Стр.ПодразделениеПредприятия = Стр.СпособОтраженияЗарплатыВБухучете.АналитикаРасходов; какое-то заведомо неверное выражение, например А = 1 / 0. Если ошибок не будет, значит банально не доходит до этого.
   Сергиус
 
7 - 08.06.20 - 21:33
+(6)Возможно проблема в условии проверки ТипЗнч.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.