Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

HTPP СЕРВИС

HTPP СЕРВИС
Я
   Renat11111
 
07.06.20 - 18:20
СерверАГ = "hst-api.wialon.com";        
    имяВыходногоФайла = ПолучитьимяВременногоФайла();
    ssl = Новый ЗащищенноеСоединениеOpenSSL();
    Заголовки = Новый Соответствие();
    Заголовки.Вставить("Content-Type", "application/x-www-form-urlencoded");
    HTTPСоединение = Новый HTTPСоединение(СерверАГ,,,,,,ssl );
    
    
    Результат=HTTPСоединение.Получить("wialon/ajax.html?svc=token/login&params={""token"":""МойТокен""}", имяВыходногоФайла);
    Тело = Результат.ПолучитьТелоКакСтроку();
    ЧтениеJSON = Новый ЧтениеJSON;
    ЧтениеJSON.ОткрытьФайл(имяВыходногоФайла);
    СчитатьСледующуюПозицию = Ложь;
    eid = Неопределено;
    Пока ЧтениеJSON.Прочитать() Цикл
        
        Попытка
            
            
            Если СчитатьСледующуюПозицию Тогда
                eid = ЧтениеJSON.ТекущееЗначение;
                СчитатьСледующуюПозицию = Ложь;
            КонецЕсли;
            
            
            Если ЧтениеJSON.ТекущееЗначение = "eid" Тогда
                СчитатьСледующуюПозицию = Истина;
            КонецЕсли;
            
        Исключение
            
            
        КонецПопытки;
        
    КонецЦикла;
    
    Если eid <> Неопределено Тогда
        
        
        СерверАГ = "hst-api.wialon.com";

        имяВыходногоФайла = ПолучитьимяВременногоФайла();

        ssl = Новый ЗащищенноеСоединениеOpenSSL();

        Заголовки = Новый Соответствие();

        Заголовки.Вставить("Content-Type", "application/x-www-form-urlencoded");

        HTTPСоединение = Новый HTTPСоединение(СерверАГ,,,,,,ssl );


       HTTPСоединение.Получить("wialon/ajax.html?svc=core/search_items&params={""spec"":{""itemsType"":""avl_resource"",""propName"":""reporttemplates"",""propValueMask"":""*"",""sortType"":""reporttemplates""},""force"":1,""flags"":""0x00002001"",""from"":0,""to"":0}}&sid="+eid+"");
        
    КонецЕсли;
   Renat11111
 
1 - 07.06.20 - 18:21
Кто в теме ткните носом что не так делаю eid есть
при второй попытке  HTTPСоединение.Получить("wialon/ajax.html?svc=core/search_items&params={""spec"":{""itemsType"":""avl_resource"",""propName"":""reporttemplates"",""propValueMask"":""*"",""sortType"":""reporttemplates""},""force"":1,""flags"":""0x00002001"",""from"":0,""to"":0}}&sid="+eid+"");
        
вываливается с ошибкой 

{ВнешняяОбработка.ОбработкаЗагрузкиУАТ.Форма.Форма.Форма(56)}: Ошибка при вызове метода контекста (Получить)
       HTTPСоединение.Получить("wialon/ajax.html?svc=core/search_items&params={""spec"":{""itemsType"":""avl_resource"",""propName"":""reporttemplates"",""propValueMask"":""*"",""sortType"":""reporttemplates""},""force"":1,""flags"":""0x00002001"",""from"":0,""to"":0}}&sid="+eid+"");
по причине:
Неправильный путь к файлу. Схема не зарегистрирована
   ДенисЧ
 
2 - 07.06.20 - 18:28
Для начала все числа в кавычки возьми.
А потом возьми строку получившуюся у тебя и curl'ом проверь.
   Renat11111
 
3 - 07.06.20 - 18:31
В браузере есть ответ по этой строчке
   Renat11111
 
4 - 07.06.20 - 18:31
{"searchSpec":{"itemsType":"avl_resource","propName":"reporttemplates","propValueMask":"*","sortType":"reporttemplates","propType":"","or_logic":"0"},"dataFlags":8193,"totalItemsCount":3,"indexFrom":0,"indexTo":0,"items":[{"nm":"Standard_AZ","cls":3,"id":15631916,"mu":0,"rep":{"1":{"id":1,"n":"Qrup_Ən Son Məlumat","ct":"avl_unit_group","c":15278},"2":{"id":2,"n":"Qrup_Yekun Hesabat (ünvanlarla)","ct":"avl_unit_group","c":18721},"3":{"id":3,"n":"Qrup_Ərazi","ct":"avl_unit_group","c":18819},"4":{"id":4,"n":"Qrup_Yekun Hesabat","ct":"avl_unit_group","c":5096},"5":{"id":5,"n":"Gündəlik Fəaliyyət","ct":"avl_unit","c":52236},"6":{"id":6,"n":"Qrup_Yaxınlaşan Texniki Xidmət","ct":"avl_unit_group","c":38107},"7":{"id":7,"n":"Qrup_Dayanmalar","ct":"avl_unit_group","c":52061},"8":{"id":8,"n":"Qrup_Texniki Xidmət","ct":"avl_unit_group","c":61107},"9":{"id":9,"n":"Qrup_Durmalar","ct":"avl_unit_group","c":55866},"10":{"id":10,"n":"Qrup_Rəqəmsal Giriş","ct":"avl_unit_group","c":9803},"11":{"id":11,"n":"Qrup_Səyahətlər","ct":"avl_unit_group","c":28909},"12":{"id":12,"n":"Qrup_Dayanmalar, Durmalar və Səyahətlər","ct":"avl_unit_group","c":1144},"13":{"id":13,"n":"Qrup_Yanacağın Riyazi Hesablanması","ct":"avl_unit_group","c":20495},"14":{"id":14,"n":"Sürülmənin Qiymətləndirilməsi","ct":"avl_unit","c":10609},"15":{"id":15,"n":"Qrup_Sürülmənin Qiymətləndirilməsi","ct":"avl_unit_group","c":7087},"16":{"id":16,"n":"Qrup_Yollara Əsasən Sürət Limiti","ct":"avl_unit_group","c":38070},"17":{"id":17,"n":"Qrup_Avtomobil Üzrə Sürücülər","ct":"avl_unit_group","c":25427},"18":{"id":18,"n":"Qrup_Yanacağın Normaya uyğun Sərfiyyatı","ct":"avl_unit_group","c":22161},"19":{"id":19,"n":"Məsafə","ct":"avl_unit_group","c":14147},"20":{"id":20,"n":"Qrup_Qayda Pozuntuları","ct":"avl_unit_group","c":59117},"21":{"id":21,"n":"Yekun Hesabat","ct":"avl_unit","c":4471},"22":{"id":22,"n":"Məsafə_ümumi","ct":"avl_unit_group","c":47349}},"uacl":268452387},{"nm":"Fuel_AZ","cls":3,"id":16783099,"mu":0,"rep":{"1":{"id":1,"n":"Ətraflı Yanacaq Məlumatları","ct":"avl_unit","c":37385},"2":{"id":2,"n":"Yanacağa Nəzarət (Bort)","ct":"avl_unit","c":16976},"3":{"id":3,"n":"Yanacağa Nəzarət (DUT)","ct":"avl_unit","c":30835},"4":{"id":4,"n":"Yanacağa Nəzarət (İşləmə saatları)","ct":"avl_unit","c":64830},"5":{"id":5,"n":"Yanacağa Nəzarət (Səviyyə Texnikalar)","ct":"avl_unit","c":33132}},"uacl":268452387},{"nm":"Fresh Logistics_Main","cls":3,"id":18212102,"mu":0,"rep":{"1":{"id":1,"n":"FreshFuel","ct":"avl_unit_group","c":43453},"2":{"id":2,"n":"FreshTemperature","ct":"avl_unit","c":36196},"3":{"id":3,"n":"FreshCan","ct":"avl_unit","c":30698},"4":{"id":4,"n":"FreshDoor","ct":"avl_unit","c":41641}},"uacl":17604317052903}]}
   Renat11111
 
5 - 07.06.20 - 18:35
(2) в документации не кавычки
   Renat11111
 
6 - 07.06.20 - 18:42
все разобрался вроде Спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.