Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Как ПолучитьАтрибут табличной части документа по его представлению?

v7: Как ПолучитьАтрибут табличной части документа по его представлению?
Я
   sysadminlk
 
06.06.20 - 12:32
Как ПолучитьАтрибут табличной части документа по его представлению?

ИтДкмТов=ИтДкмТов+Докум.ПолучитьАтрибут(ТипИтога);
{Документ.НалоговыйПриход.Форма.Модуль(62)}: Неверное имя атрибута


Функция Получить(Твр,ТипИтога)
    Док = СоздатьОбъект("Документ.Приходная");
    Док.НайтиДокумент(Докум);
    ИтДкмТов = 0;
    Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку() = 1 Цикл
        Если Твр = Док.Товар Тогда
            ИтДкмТов=ИтДкмТов+Док.ПолучитьАтрибут(ТипИтога);
        КонецЕсли;
    КонецЦикла;
    Возврат ИтДкмТов;    
КонецФункции

где ТипИтога это символьное представление реквизита табличной части Документ.Приходная

Можно конечно через через Если обыграть типо
Если ТипИтога = "Сумма" тогда
ИтДкмТов=ИтДкмТов+Док.Сумма;
ИначеЕсли ТипИтога = "НДС" тогда
ИтДкмТов=ИтДкмТов+Док.НДС;

Но хотелось бы без условий просто получить к нужное поле табличной части документа
   sysadminlk
 
1 - 06.06.20 - 12:52
Разобрался. Оказалось что в ТипИтога действительно прилетал Неверное имя атрибута ))) которого нет в документе.
тема закрыта
   Злопчинский
 
2 - 06.06.20 - 13:38
(0) не путай Представление, и Идентификатор и Синоним.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.