Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Наложить отбор по имени

Наложить отбор по имени
Я
   asn-sasha
 
04.06.20 - 15:15
Уважаемые эксперты! Прошу вашей подсказки, старший программист сказал сделать отбор по (Имени) в НоваяСтрока.Имя  = СтрокаДерева.Имя; а именно в СтрокаДерева.Имя

Попытался через точку СтрокаДерева.Имя. , но никах методов нет открывается.

Как можно наложить отбор на СтрокаДерева.Имя? мне нужно в отборе указать ЗаказПокупателя и РеализациюТоваровИУслуг
   asn-sasha
 
1 - 04.06.20 - 15:15
Вот весь код:

Процедура ОбновитьТаблицу(Ссылка)
    
    Попытка
        Объект = Ссылка.ПолучитьОбъект();
        СтруктураВнутреннихПечатныхФорм = Объект.ПолучитьСтруктуруПечатныхФорм()
    Исключение
        СтруктураВнутреннихПечатныхФорм = Новый Структура;
    КонецПопытки;
    
    Дерево = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(Ссылка, СтруктураВнутреннихПечатныхФорм,,,Ложь);
    Для Каждого СтрокаДерева Из Дерево.Строки Цикл
        Если ТаблицаМакетовПечати.Найти(СтрокаДерева.Текст,"ПечатнаяФорма") <> Неопределено Тогда
            Продолжить;
        КонецЕсли;
        НоваяСтрока = ТаблицаМакетовПечати.Добавить();
        НоваяСтрока.ПечатнаяФорма = СтрокаДерева.Текст;
        НоваяСтрока.Расшифровка   = СтрокаДерева.Расшифровка;
        НоваяСтрока.Имя           = СтрокаДерева.Имя;
        
        //СтрокаДерева.ТипКнопки

    КонецЦикла;
    //ЭлементыФормы.ДеревоМакетовПечати.СоздатьКолонки();

    

    
КонецПроцедуры
   shuhard
 
2 - 04.06.20 - 15:38
(0)[старший программист сказал сделать ]
так задай ему вопрос
   ГдеСобакаЗарыта
 
3 - 04.06.20 - 15:38
Ты невмимательно слушал старшего программиста. Никакой отбор на СтрокаДерева.Имя наложить нельзя. Сходи еще раз спроси, что нужно сделать
   dka80
 
4 - 04.06.20 - 15:39
Отбор = Новый Структура("Имя", нужноетебеимя);
Строки = Дерево.Строки.найтиСтроки(Отбор);
Для Каждого Строка Из Строки Цикл
и далее твой цикл
   asn-sasha
 
5 - 04.06.20 - 16:09
(2) (3) (4) Всем спасибо) перепутали
   asn-sasha
 
6 - 04.06.20 - 16:09
а как тогда тут наложить отбор

Процедура ТипДокументаНачалоВыбора(Элемент, СтандартнаяОбработка)
    
    СтандартнаяОбработка = ложь;
    
    ТаблицаДок = Новый ТаблицаЗначений;
    ТаблицаДок.Колонки.Добавить("ТипДокумента",,"Тип документа");
    Для Каждого ТипДокумент Из Метаданные.Документы
        Цикл
        НоваяСтрока = ТаблицаДок.Добавить();
        НоваяСтрока.ТипДокумента = ТипДокумент;
    КонецЦикла;
    СтрокаТипа = ТаблицаДок.ВыбратьСтроку();
    Если СтрокаТипа <> Неопределено Тогда
        ТаблицаМакетовПечати.Очистить();
        ДокументыДляОбработки.Очистить();
    иначе
        Возврат;
    КонецЕсли;
    ДокументМетоданные = СтрокаТипа.ТипДокумента;
    ТипДокумента = СтрокаТипа.ТипДокумента;
    
    ОбновитьТаблицуДокументов();
    
КонецПроцедуры
   asn-sasha
 
7 - 04.06.20 - 16:10
как мне ограничить метаданные из выбор Метаданные.Документы? Мне нужно чтобы был отбор только по Заказу покупателя и Реализации
Подскажите плс, пол дня голову ломаю, заранее благодарен
   Ёпрст
 
8 - 04.06.20 - 16:39
(7) там вообще отбор не нужен, просто добавь 2 строки в таблицу свою с 2-мя типами метаданных
   Ёпрст
 
9 - 04.06.20 - 16:39
и цикл по метаданным документов выкинь

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.