Вход | Регистрация
 

Не могу присвоить значение строки

Не могу присвоить значение строки
Я
   Nemirov
 
04.06.20 - 15:11
Не получается присвоить ТабСтр.НоменклатураТП значение Справочники.Номенклатура.НайтиПоНаименованию(Стр.Наименование); пустые ссылки  на всех реквизитах. Кто встречался с такой бедой подскажите в чем может быть причина?
            Для Каждого Стр Из тзРезультат Цикл
                
                ТаблицаДляПостроителя = Новый ТаблицаЗначений;
                ТаблицаДляПостроителя.Колонки.Добавить("НоменклатураТП",Новый ОписаниеТипов("СправочникСсылка.Номенклатура"));
                
                ТабСтр  = ТаблицаДляПостроителя.Добавить();
                ТабСтр.НоменклатураТП = Справочники.Номенклатура.НайтиПоНаименованию(Стр.Наименование);
                
                Если НЕ ИспользоватьАртикул Тогда
                    
                    Если ТабЗначКодыПоставщика.Количество() > 0 Тогда
                        Построитель = Новый ПостроительЗапроса;
                        Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(ТабЗначКодыПоставщика);
                        СтрокаОтбора = Построитель.Отбор.Добавить("НоменклатураКодыПоставщика");
                        СтрокаОтбора.ВидСравнения  = ВидСравнения.Равно;
                        СтрокаОтбора.Значение      = ТабСтр.НоменклатураТП;
                        СтрокаОтбора.Использование = Истина;
                        Построитель.Выполнить();
                        ВременнаяТЗ = Построитель.Результат.Выгрузить();
                        КолВо =  СтрокаОтбора.Значение.КодЧ;
                        Если Колво > 0 Тогда                                
                            Стр.НоменклатураСсылка = ТабСтр.НоменклДляПостр;        
                        Иначе
                            Сообщить("Нет привязки номенклатуры " + СокрЛП(Стр.Наименование),СтатусСообщения.ОченьВажное);
                            Отказ = Истина;
                        КонецЕсли;
                        
                    КонецЕсли;
                    
                Иначе
                    Стр.НоменклатураСсылка = омРаботаСФормами.ПолучитьАртикулПоставщика(ЭтотОбъект.Дата,Стр.Номенклатура,Стр.ЕдиницаИзмерения,ЭтотОбъект.Контрагент,ЭтотОбъект.Договор,Стр.Характеристика);
                КонецЕсли;    
                
            КонецЦикла;
   ГдеСобакаЗарыта
 
1 - 04.06.20 - 15:19
Какой ужас. Стыдно должно быть выкладывать такое на всеообщее обозрении. Все удали и перепиши как следует.
   dka80
 
2 - 04.06.20 - 15:35
Справочники.Номенклатура.НайтиПоНаименованию(Стр.Наименование) - в отладчике что возвращает?
   Волшебник
 
Модератор
3 - 04.06.20 - 15:39
Вместо
СтрокаОтбора.ВидСравнения  = ВидСравнения.Равно;
СтрокаОтбора.Значение      = ТабСтр.НоменклатураТП;
СтрокаОтбора.Использование = Истина; 

можно 

СтрокаОтбора.Установить(ТабСтр.НоменклатураТП);
   Nemirov
 
4 - 04.06.20 - 15:43
(2) Пустые ссылки, хотя сама СТр.Наименование имеет значение. Может по умолчанию ищет точное совпадение ?
   Волшебник
 
Модератор
5 - 04.06.20 - 15:45
(4) встаньте курсором на НайтиПоНаименованию и нажмите Ctrl-F1
   dka80
 
6 - 04.06.20 - 15:46
(4) в смысле у тебя в наименовании написано "масло", а в справочнике "супер масло"? Тогда точно не найдет. Ставь не точное совпадение
   Nemirov
 
7 - 04.06.20 - 15:48
(6) Короче нашлась причина походу: к примеру Стр.Наименовании "Масло доз" а в справочнике "Масло доз."
   Nemirov
 
8 - 04.06.20 - 15:49
(6) И как быть в такой ситуации? Просто все наименования не меняются, а бывает что вот такие точки или другие символы добавляются(
   dka80
 
9 - 04.06.20 - 15:50
Справочники.Номенклатура.НайтиПоНаименованию(Стр.Наименование, ЛОжь), но за результат я не отвечаю
   Nemirov
 
10 - 04.06.20 - 15:58
(9) Да пробовал, ладно спасибо буду думать сам
   Timon1405
 
11 - 04.06.20 - 16:02
Запросом искать Номенлкатуру
Где Наименование подобно &СтрокаПоиска+"%"

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.