Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ЗУП 3.1 в СЗВ-ТД не заполняются номера документов основания.

ЗУП 3.1 в СЗВ-ТД не заполняются номера документов основания.
Я
   Креатив
 
04.06.20 - 10:21
В форме мероприятий дата приказа есть, а номер отсутствует. Ручное редактирование запрещено.
В чём может быть причина?
   spiller26
 
1 - 04.06.20 - 10:31
(0) Если не на поддержке, то разреши редактирование этой колонки. Или расширение запили, если разрешающее.
   SleepyHead
 
2 - 04.06.20 - 10:43
(0) Была такая проблема в одном из релизов, в 3.1.13.188 исправлено.
   Креатив
 
3 - 04.06.20 - 10:44
(2)Поставил уже 3.1.14, а проблема осталась.
   SleepyHead
 
4 - 04.06.20 - 10:49
(3) Варианты решения:

1. Раздел "Настройки" - "Дополнительные настройки" - "Удалять префиксы организации из номеров кадровых приказов" - установлен? Если да, то далее все зависит от номера приказа в документе. Если в номере два "тире" то номер превращается в тыкву, становится пустым.

2. В 3.14 можно уже заполнить поле "Номер для печати", который пойдет в СЗВ-ТД
   Фрэнки
 
5 - 04.06.20 - 10:55
(3) В кадровых, которые являются источником для заполнения мероприятий - там добавлено еще одно поле для Номера

Я просто дополняют ответ в (4)
Там если в настройках для печати в самой кадровой подсистеме идет сочетание условий, то на последних релизах сделали нарочно вот это дополнительное поле. Но если это поле пустое, то и выдавать будет пустой номер.
Можно допилить расширением эту процедуру так, чтоб оно корректно срабатывала и даже пустые поля хоть какой-то строкой дополняла.
   SleepyHead
 
6 - 04.06.20 - 10:57
"Там если в настройках для печати в самой кадровой подсистеме идет сочетание условий"

Можно подробнее? Что именно за сочетание и какие именно настройки?
   Фрэнки
 
7 - 04.06.20 - 11:15
Вызывается при работе с заполнением электронных трудовых вот эта функция
Функция НомерНаПечать(Знач Номер, Знач НомерПриказа = Неопределено) Экспорт
    
    Если ЗначениеЗаполнено(НомерПриказа) Тогда
        Возврат СокрЛП(НомерПриказа);
    КонецЕсли;
    
    НастройкиПечатныхФорм = ЗарплатаКадры.НастройкиПечатныхФорм();
    
    Если НастройкиПечатныхФорм.УдалятьПрефиксыОрганизацииИИБИзНомеровКадровыхПриказов Тогда
        Номер = ПрефиксацияОбъектовКлиентСервер.НомерНаПечать(Номер, Истина, Истина);
    КонецЕсли;
    
    Возврат Номер;
    
КонецФункции

Я в старую конфигурацию сейчас не полезу, но раньше код у этой функции был немного другой.

Т.е. сейчас в приоритете идет поле НомерПриказа. Если оно не пустое, но оно и используется. Это новое поле.
А по старым условиям - вот эта префиксация...
Там внутри реагирует на отдельные символы, которые могут выдавать пустую строку.
   SleepyHead
 
8 - 04.06.20 - 12:00
(7) Спасибо, я уже думал, что еще какие-то условия поменяли. Но пока вижу, все как раньше, за исклоючением номера, ввденного вручную.

У моих клиентов номера были типа ЗПК-00071к-12

И когда было 2 тире, номер в СЗВ-ТД шел пустой, вообще. И я понимаю почему, "-" отделяет префиксы и на такой финт модули префиксации не были рассчитаны. Имел переписку с техподдержкой на этот счет, и видимо, не один я, после чего ввели номера, которые можно заполнять вручную.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.