Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УТ 11 Сканер штрих обработать событие считывания во внешней обработке

УТ 11 Сканер штрих обработать событие считывания во внешней обработке
Я
   1c_solop
 
04.06.20 - 08:57
Установлен эмулятор сканер штрих кода везде видит в обработке не видит.
Что не хватает
Нужно чтоб сработала обработка оповещения
В обработке есть
&НаКлиенте
Процедура ПриОткрытии(Отказ)
        МенеджерОборудованияКлиент.НачатьПодключениеОборудованиеПриОткрытииФормы(Неопределено, ЭтаФорма, "СканерШтрихкода");

КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
        ОбщегоНазначенияУТ.НастроитьПодключаемоеОборудование(ЭтаФорма);

    КонецПроцедуры
&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
    
    Если Источник = "ПодключаемоеОборудование" И ВводДоступен() Тогда
        Если ИмяСобытия = "ScanData" И МенеджерОборудованияУТКлиент.ЕстьНеобработанноеСобытие() Тогда
            ОбработатьШтрихкоды(МенеджерОборудованияУТКлиент.ПреобразоватьДанныеСоСканераВСтруктуру(Параметр));
        КонецЕсли;
    КонецЕсли;
    
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.