Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Условие в печатной форме

v7: Условие в печатной форме
Я
   Rononoa
 
02.06.20 - 07:45
Есть колонка. которая в зависимости от переменной КомпенсацияВозмещение (которое я присвоил значения либо 1 либо 2) должна выводить либо дробное, т.е #Ч-10.2., Либо целое, т.е т.е #Ч-10.0., Решения, которые я нахожу они все через запрос делаются, но там конретно меняется порой значение колонки, мне же просто надо изображать одно и то же значение по-разному.
   Aleksey
 
1 - 02.06.20 - 07:52
#Ч-10.2., можно заменить на формат. в типовой к примеру через глФРМ выводят цифры
   Kigo_Kigo
 
2 - 02.06.20 - 07:59
?(котороеяприсвоилзначениялибо = 1,Сумма#Ч-10.2,Сумма#Ч-10.0)
   Rononoa
 
3 - 02.06.20 - 09:24
Да и ещё, неохота создавать отдельный топик
Создал элемент справочника "ДатаНачала"
В документе сослался на него
Пока СоставНормы.ПолучитьЭлемент()=1 Цикл 
 НормаОбмундирования.НоваяСтрока();
 НормаОбмундирования.ДатаНачала       = СоставНормы.ДатаНачала;

В итоге мне пишет что поле агрегатного объекта не обнаружено, но такое должно писать насколько я знаю, когда ты ссылаешься на несуществующий элемент справочника
   ДенисЧ
 
4 - 02.06.20 - 09:27
А отладчик что говорит? На какую часть выражения ругается?
   Kigo_Kigo
 
5 - 02.06.20 - 09:28
Что значит элемент справочника?
   Rononoa
 
6 - 02.06.20 - 09:30
Ну т.е Реквизит справочника
   Rononoa
 
7 - 02.06.20 - 09:32
А Отладчик я не гляну, так как обновлял во время обеда и сейчас уже люди работают
(да, можно ли документ сохранить в файл, чтобы без обновления конфигурации над ним работать)
   Kigo_Kigo
 
8 - 02.06.20 - 09:36
Использовать, что стоит - для элемента?
   Rononoa
 
9 - 02.06.20 - 09:44
Это Где?
   Rononoa
 
10 - 02.06.20 - 09:45
А все туплю, стоит для элемента и никак не поменять
   aka AMIGO
 
11 - 02.06.20 - 10:34
" А Отладчик не гляну.. люди работают"
Хм. я не гуру, но написал себе простейший баничек, копирую себе (из сервера на свой пк) все dbf, юезеров и, конечно, MD  с DD
И отлаживаю, сколько моей душеньке угодно.
Вовсе нет необходимости сидеть в рабочей базе.
   Rononoa
 
12 - 02.06.20 - 11:22
Это как, можно подробнее
   Kigo_Kigo
 
13 - 02.06.20 - 13:33
Пока СоставНормы.ПолучитьЭлемент()=1 Цикл 
Если СоставНормы.ЭтоГруппа() = 1 ТОгда
Продолжить;
КонецЕсли;
 НормаОбмундирования.НоваяСтрока();
 НормаОбмундирования.ДатаНачала       = СоставНормы.ДатаНачала;
   Builder
 
14 - 02.06.20 - 13:40
Уже откройте для себя 
#ЗагрузитьИзФайла ТвойФайл.txt  -  очень удобно модули менять на ходу.
Или внешние печатные формы.
Ну и отладчиком можно пользоваться и на рабочей базе, как ни странно.
   ДенисЧ
 
15 - 02.06.20 - 13:44
(7) А как связаны отладчик и люди? О_о
   Rononoa
 
16 - 03.06.20 - 04:03
У меня полный цикл вот

Пока СоставНормы.ПолучитьЭлемент()=1 Цикл 
            Если СоставНормы.ПометкаУдаления()=1 Тогда
                Продолжить;
            КонецЕсли
   Rononoa
 
17 - 03.06.20 - 04:26
Отладчик и люди связаны тем, что когда я в отладчике, то у меня программа запускается монопольно, чего я проделать не могу, когда уже в базе люди
   victuan1
 
18 - 03.06.20 - 04:37
(17) Отладчик вовсе не требует монопольный режим.
   Rononoa
 
19 - 03.06.20 - 04:44
Хм, а как тогда мне запускать, просто в конфигураторе понятно я монопольно, из него я запускаю отладчик - он тоже монопольно, а из отладчика уже 1с - он тоже монопольно становится. Может тогда отдельно запускать?
   Rononoa
 
20 - 03.06.20 - 06:38
Да и может ли такая ошибка возникать из-за того, что в коде уже есть переменная ДатаНачала и ДатаОкончания. Тут я справочник подтягиваю и чтобы было понятно присвоил новым реквизитам такие идентификаторы
   victuan1
 
21 - 03.06.20 - 07:17
(19) Конфигуратор тоже не запускается монопольно. Монопольный режим требуется только для сохранения изменений в конфигурации.
   Rononoa
 
22 - 03.06.20 - 08:18
НУ вот отлачик в стеке вызовов показал ещё и эту процедуру

Процедура ОбработкаВыбораЗначения(ВыбЗнач,ЭлемДиалога,Флаг)  
    Если ЭлемДиалога="Сотрудник" Тогда  
        Флаг=0;
        Сотрудник=ВыбЗнач; 
        ПриВыбореСотрудника();
    ИначеЕсли (ЭлемДиалога="Обмундирование") Тогда 
         Флаг = 0;
         ПриВыбореОбмундирования(ВыбЗнач);  
    КонецЕсли;

КонецПроцедуры


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.