Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не отображаются элементы справочника при программном создании

Не отображаются элементы справочника при программном создании
Я
   FrostBite101
 
01.06.20 - 11:04
Элементы появляются при запуске конфигурации. В форме списка кнопка1

&НаСервере
Процедура Изменить()
    
    Для Счетчик = 1 По 5 Цикл
      Объект = Справочники.Клиенты.СоздатьЭлемент();
      Объект.Наименование = Счетчик ;
      Объект.Записать();
    КонецЦикла;
      
    
  КонецПроцедуры

&НаКлиенте
  Процедура Команда1(Команда)
      Изменить();
  КонецПроцедуры
 
 Партнерская программа EFSOL Oblako
   strange2007
 
1 - 01.06.20 - 11:33
А что за конфигурация?
   fisher
 
2 - 01.06.20 - 11:54
И не должны.
При стандартных командах создания/изменения элементов в динамических списках платформа заботится об обновлении списков автоматически (и то только для тех списков, которые являются основными реквизитами открытых форм).
При программном изменении программист должен это сделать явно через вызов метода глобального контекста ОповеститьОбИзменении
   fisher
 
3 - 01.06.20 - 11:59
Ну а в контексте конкретной формы списка можно просто его обновить напрямую - через ОбновитьОтображениеДанных

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.