Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Запись изменений GetInfoBases()

Запись изменений GetInfoBases()
Я
   Servang
 
29.05.20 - 06:31
Здравствуйте!
ПОдскажите, пожалуйста, как можно записать изменения в настройках базы.
Например, я хочу изменить ScheduledJobsDenied

Для каждого Кластер из Кластеры Цикл
                    
                    Агент.Authenticate(Кластер, , );
                    
                    ИнформационнаяБаза = "";
                    ИнформационнаяБазаНайдена = Ложь;
                    
                    Процессы = Агент.GetWorkingProcesses(Кластер);
                    Для каждого Процесс из Процессы Цикл
                        Порт = Процесс.MainPort;
                        РабПроц = COMСоединитель.ConnectWorkingProcess("WIN-5V7NN9TTHQ5" + ":" + СтрЗаменить(Порт, Символы.НПП, ""));
                        РабПроц.AddAuthentication("Админ", "");
                        
                        InfoBases = РабПроц.GetInfoBases();
                        
                        Для каждого База из InfoBases Цикл
                            Если База.Name = "leK" Тогда
                                ИнформационнаяБаза = База;
                                ИнформационнаяБазаНайдена = Истина;
                                Прервать;
                            КонецЕсли;
                        КонецЦикла;
                        
                        ИнформационнаяБаза.ScheduledJobsDenied = Ложь;
                        
                        //Если ИнформационнаяБазаНайдена Тогда            
                        //    Если не ИнформационнаяБаза.ScheduledJobsDenied тогда
                        //        ИнформационнаяБаза.ScheduledJobsDenied = Истина;
                        //    КонецЕсли;
                        //    Прервать;
                        //КонецЕсли;
                        
                    КонецЦикла;
                    
                    Если не ИнформационнаяБазаНайдена тогда
                        Сообщение = новый СообщениеПользователю;
                        Сообщение.Текст = "Информационная база" + "leK" + " не найдена!";
                        Сообщение.Сообщить();
                    КонецЕсли;    
                    
                КонецЦикла;
   Servang
 
1 - 29.05.20 - 06:32
Ибо если я просто меня на ложь/истина, то он меняется но не записывается
   Галахад
 
2 - 29.05.20 - 07:57
Попробуй

РабПроц.UpdateInfoBase(ИнформационнаяБаза)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.