Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УТ10 как обратиться к свойствам номенклатуры програмно

УТ10 как обратиться к свойствам номенклатуры програмно
Я
   lite777
 
28.05.20 - 13:00
Добрый день, ут10, форма элемента номенклатура, вкладка свойства , заполнены поля свойста и значение (несколько свойств) в табл части, нужно при изменении значения свойство формировать название номенклатуры -пытаюсь так-

// Обработчик события ПриИзменении элемента СвойстваИЗначения.Значение.
//
Процедура СвойстваИЗначенияЗначениеПриИзменении(Элемент)

    Модифицированность = Истина;
    
    СформироватьНазвание() ;


КонецПроцедуры // СвойстваИЗначенияЗначениеПриИзменении()

//777
Процедура СформироватьНазвание()
    
    Для каждого стр из  ЭлементыФормы.СвойстваИЗначения Цикл
        Наименование=Наименование+" "+стр.Значение ;
    КонецЦикла ;    
    
КонецПроцедуры    

{Справочник.Номенклатура.Форма.ФормаЭлемента(1772)}: Итератор для значения не определен
    Для каждого стр из  ЭлементыФормы.СвойстваИЗначения ??? Цикл
   lite777
 
1 - 28.05.20 - 13:01
ЭлементыФормы.СвойстваИЗначения -тип-ТабличноеПоле
   lite777
 
2 - 28.05.20 - 15:14
Сам отвечу -надо было так-
  Для каждого стр из  ЭлементыФормы.СвойстваИЗначения.Значение Цикл

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.