Вход | Регистрация
 

Заполнение состава свойств характеристик

Заполнение состава свойств характеристик
Я
   falselight
 
28.05.20 - 11:20
УНФ 1.6. Подскажите пожалуйста по такой задаче.
При заведении характеристик номенклатуры, нужно что бы состав свойств заполнялся из общего набора свойств для характеристик.
Что бы при создании характеристик, отобразились нужные заданные свойства автоматически.
Так как получается что вводят не те свойства.
Подскажите пожалуйста как это правильно сделать или доработать, и где?
   falselight
 
1 - 28.05.20 - 13:03
UP!
   falselight
 
2 - 28.05.20 - 13:13
как в номенклатуре, у которой задан флаг вести учет по характеристикам
при создании характеристики, управлять содержимым вот этих свойств
что бы они не менялись, и стояли все, необходимые, если даже указать категорию?
а то при указании категории свойства меняются.

http://joxi.ru/gmvaZ43tvEWY6r
   falselight
 
3 - 28.05.20 - 13:22
так как, если у номенклатуры, у которой ведется учет по характеристикам, создавать характеристику
там в свойствах есть все необходимые свойства
но если указать категорию то, свойства меняются

как повлиять на то что бы они не меняются, кто знает. буду благодарен подсказке.

http://joxi.ru/Q2KbdNVCwoPNYm
   Ненавижу 1С
 
4 - 28.05.20 - 13:26
в видах номенклатуры
   falselight
 
5 - 28.05.20 - 13:31
(4) А что там? Подскажите если не трудно.
Пока по коду лажу при создании характеристики из номенклатуры по ссылке.

Нужно что бы состав свойств не менялся если указана категория.

Вошел в эту процедуру.

Процедура ТаблицаСвойствПриСозданииНаСервере(Форма, Объект = Неопределено, ВладелецСвойств = Неопределено, ЗаполнитьОписаниеЗависимостей = Истина) Экспорт

думаю в ней что то происходит, что влияет на мой вопрос.
   falselight
 
6 - 28.05.20 - 13:39
тут вот ещё добавляется

Процедура ЗаполнитьСписокСвойствОбъектаХарактеристика(Форма, СписокСвойств)
    
    СписокСвойств.Добавить("Наименование", Форма.Объект.Наименование);
    
    Для каждого Свойство Из Форма.Свойства_ТаблицаСвойстваИЗначения Цикл
        
        НаименованиеСвойства = Строка(Свойство.Свойство);
        ЗначениеСвойства     = Свойство.Значение;
        
        Если ТипЗнч(ЗначениеСвойства) = Тип("Булево") Тогда
            ЗначениеСвойства = ?(ЗначениеСвойства = Истина, Свойство.Наименование, "");
        КонецЕсли;
        
        СписокСвойств.Добавить(НаименованиеСвойства, ЗначениеСвойства);
        
    КонецЦикла;
    
КонецПроцедуры
   Ненавижу 1С
 
7 - 28.05.20 - 13:44
рано еще по коду лазить, попробуйте изучить систему с точки зрения пользователя
как можно задать характеристику: индивидуально на товар, по виду номенклатуры, общую на несколько видов номнклатуры
   falselight
 
8 - 28.05.20 - 14:00
(7) Нужно решить задачу.

Если указана категория, что бы не менялся состав свойств.
Он меняется если указана категория.
Если она не указана, то состав свойств необходимый.
   falselight
 
9 - 28.05.20 - 14:01
оперативный поиск, привел к таким корректировкам

            //Категория = Форма.КатегорияНоменклатуры;

            Категория = Справочники.КатегорииНоменклатуры.НайтиПоНаименованию("<Без категории>",1);
   Ненавижу 1С
 
10 - 28.05.20 - 14:10
   falselight
 
11 - 28.05.20 - 14:17
(9) это не помогло ((( все равно если выбирается категория на форме, номенклатуры
то при создании характеристики, её набор свойств меняется, хотя я программно попробовал указать, что без категорий...
   falselight
 
12 - 28.05.20 - 14:20
(10) как то замудренно, нужно разбираться, этот ли вопрос

у меня вопрос простой.

выбирается категория у номенклатуры. или не выбирается, что бы набор свойств не менялся

я возможно не вошел ещё в весь процесс......
   falselight
 
13 - 28.05.20 - 15:01
Пока не знаю как это решить
подмена в коде категории на <Без категории>

ничего не дает ((((

Интересно где что даст?
   Масянька
 
14 - 28.05.20 - 15:04
(13) А в справочнике есть такая запись? <Без категории>
   falselight
 
15 - 28.05.20 - 15:11
(14) Конечно!!!!!!!


http://joxi.ru/Dr8De5vTz6O6Or
   falselight
 
16 - 29.05.20 - 05:43
Никто не знает, где сделать так что бы при выборе категории не менялся состав свойств при создании характеристики ???
   falselight
 
17 - 29.05.20 - 05:44
Я прописал уже где только можно!

&НаСервере
// Процедура - заполняет список выбора для реквизита Владелец.

//
Процедура ЗаполнитьСписокВыбораВладельца()
    
    Элементы.Владелец.СписокВыбора.Очистить();
    Если ЗначениеЗаполнено(КатегорияНоменклатуры) Тогда
        Элементы.Владелец.СписокВыбора.Добавить(КатегорияНоменклатуры);
    КонецЕсли;
    Если ЗначениеЗаполнено(Номенклатура) Тогда
        Элементы.Владелец.СписокВыбора.Добавить(Номенклатура);
    КонецЕсли;
   falselight
 
18 - 29.05.20 - 08:55
але
   falselight
 
19 - 29.05.20 - 10:03
как сослаться если не выбрана категория, то не переписывать свойства
   Масянька
 
20 - 29.05.20 - 10:05
(15) Я, вообще-то, про справочник спрашивала.
   falselight
 
21 - 29.05.20 - 10:12
(20) где это делать?
   falselight
 
22 - 30.05.20 - 09:15
По коду вот это значение

Строка.Набор = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Категория, "НаборСвойствХарактеристики");

= СправочникСсылка.НаборыДополнительныхРеквизитовИСведений

я задаю это значение сам

Строка.Набор = Справочники.НаборыДополнительныхРеквизитовИСведений.НайтиПоНаименованию("<Без категории>",1);

но тогда, перестает работать? Почему?

    Если ЗначениеЗаполнено(Категория) Тогда
        Строка = НаборыСвойств.Добавить();
        //Категория = Справочники.КатегорииНоменклатуры.НайтиПоНаименованию("<Без категории>",1);

        //Строка.Набор = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Категория, "НаборСвойствХарактеристики");

        Строка.Набор = Справочники.НаборыДополнительныхРеквизитовИСведений.НайтиПоНаименованию("<Без категории>",1);
        // <-

    КонецЕсли;
    
КонецПроцедуры
   falselight
 
23 - 30.05.20 - 09:22
на форме в категории значение "<Без категории>"

и я возвращаю его же

1.        //Строка.Набор = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Категория, "НаборСвойствХарактеристики");

2.        Строка.Набор = Справочники.НаборыДополнительныхРеквизитовИСведений.НайтиПоНаименованию("<Без категории>",1);


почему строка 1 работает, а строка 2 нет? Свойства не заполняются вообще!!!!

значение же одно и тоже

http://joxi.ru/VrwRa43H8G7n5A
   МимохожийОднако
 
24 - 30.05.20 - 09:38
(15) Это значение Неопределено. А отображается <Без категории>
   falselight
 
25 - 30.05.20 - 09:48
(24) Я разобрался в чем дело
решение такое, -

        Строка.Набор = Справочники.НаборыДополнительныхРеквизитовИСведений.НайтиПоНаименованию("<Без категории>",1,Справочники.НаборыДополнительныхРеквизитовИСведений.НайтиПоНаименованию("Характеристики", 1));


Подвох был в том что находился элемент "<Без категории>" но другого родителя. По этому заполнение свойствами вообще не происходило.

Долго просидел с этим. Пока не развернул свойства найденных элементов и не увидел что они различны, по родителю


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.