Вход | Регистрация
 

Работа с макетом

Работа с макетом
Я
   1Слайт
 
26.05.20 - 23:52
доброго времени суток
нужно список номеров занести в таблицу.
ограничивая количество строк.
допустим список из 8 номеров - в первый столбец записываем первые 5 номеров, остальные 3 должны записаться в соседний столбец
не понимаю как продолжить запись...
подскажите метод, пож-та
   МимохожийОднако
 
1 - 26.05.20 - 23:54
Объяснение задачи невнятное. Приведи конкретный пример. Озвучь цель, а не предполагаемые инструменты
   1Слайт
 
2 - 26.05.20 - 23:56
(1) цель- сделать опись документов - примитивная таблица со списком номеров
Пока Выборка.Следующий() Цикл
                ОбластьЗначенияТабл.Параметры.Папка = Выборка.Папка;            
                ВыборкаДокументов = Выборка.Выбрать();
                КолСтрок = КолСтрок + 1;
                ТабДок.Вывести(ОбластьЗначенияТабл);
                    Пока ВыборкаДокументов.Следующий() Цикл
                        ОбластьЗначенияТаблРегНом = ОбъектМакет.ПолучитьОбласть("ЗначенияТаблРегНом);
                        Если ВыборкаДокументов.КолЭкз > 1 Тогда 
                            ОбластьЗначенияТаблРегНом.Параметры.РегНомер1 = ВыборкаДокументов.РегНомер + " " + Формат(ВыборкаДокументов.КолЭкз,"ЧГ=0") + " экз.";
                        Иначе 
                            ОбластьЗначенияТаблРегНом.Параметры.РегНомер1 = ВыборкаДокументов.РегНомер;
                        КонецЕсли;
                        ТабДок.Вывести(ОбластьЗначенияТаблРегНом);
                    КонецЦикла;
                    
            КонецЦикла;
   МимохожийОднако
 
3 - 26.05.20 - 23:58
Посмотри как делается шахматка или печать этикеток.
   1Слайт
 
4 - 27.05.20 - 00:24
(3) ничего подобного не нахожу
кто подскажет метод/инструменты?
   Chameleon1980
 
5 - 27.05.20 - 04:59
разделяй перед выводом и кури присоединить
   1Слайт
 
6 - 02.06.20 - 22:38
Ребят, помогите реализовать причуды заказчика
сейчас в таблицу заносятся номера документов, с увеличением номера по строке (в таблице должно быть не более 5 столбцов)

1   2   3   4   5
6   7   8   9   10
11  12  13  14  15
16  17  18  19

а нужно чтобы по столбцу по увеличению
1   6   10   14   18
2   7   11   15   19
3   8   12   16
5   9   13   17

ДОкументов может быть несколько  сотен (переменная КолДокПоПапке),
есть переменная КолСтрок  = количество док-в делим на стобцы, получаем максимальное кол-во строк в таблице
не могу правильно выразить в коде: выводить номера в столбец пока в таблице не будет строк =КолСтрок, чтобы запись пошла в следующий столбец
Пока Выборка.Следующий() Цикл
                ОбластьЗначенияТабл.Параметры.Папка = Выборка.Папка;            
                ВыборкаДокументов = Выборка.Выбрать();
                КолСтрок = Выборка.КолДокПоПапке/5;
                //Сообщить (КолСтрок);

                к=0;
                ТабДок.Вывести(ОбластьЗначенияТабл);
                Пока ВыборкаДокументов.Следующий() Цикл
                    ОбластьЗначенияТаблРегНом = ОбъектМакет.ПолучитьОбласть("ЗначенияТаблРегНом|Колонка1");
                    Если ВыборкаДокументов.КолЭкз > 1 Тогда 
                        ОбластьЗначенияТаблРегНом.Параметры.РегНомер = ВыборкаДокументов.РегНомер + " " + Формат(ВыборкаДокументов.КолЭкз,"ЧГ=0") + " экз.";
                    Иначе 
                        ОбластьЗначенияТаблРегНом.Параметры.РегНомер = ВыборкаДокументов.РегНомер;
                    КонецЕсли;  
                                
                    Если к = 0 Тогда  
                        ТабДок.Вывести(ОбластьЗначенияТаблРегНом);
                        к=1;
                    Иначе 
                        ТабДок.Присоединить(ОбластьЗначенияТаблРегНом);
                        к=к+1;
                    КонецЕсли;  
                    Если к=5 Тогда
                        к=0;
                    КонецЕсли;
                КонецЦикла;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.