Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Программное удаление отбора в СКД

Программное удаление отбора в СКД
Я
   Cоляпсус
 
21.05.20 - 12:00
Добрый день. Тема не раз уже поднималась, но вот мне победить её не получается.
Стоит отбор. Его при кнопке очистка необходимо либо удалить, либо снять галку использование.
Попробовал метод удалить
Для Каждого Стр Из КомпоновщикНастроек.Настройки.Отбор.Элементы Цикл
КомпоновщикНастроек.Настройки.Отбор.Элементы.Удалить(Стр);
КонецЦикла;
Попробовал
Для Каждого Стр Из КомпоновщикНастроек.Настройки.Отбор.Элементы Цикл
Стр.Использование = Ложь;
КонецЦикла;
Может кто подскажет, как же всётаки сделать.
Заранее благодарен
   Momus
 
1 - 21.05.20 - 12:07
Не знаю как правильно, но если делать то, что выше, для пользовательских настроек, то все работает
   Cоляпсус
 
2 - 21.05.20 - 12:11
(1) Пользовательские настройки не содержат в себе записей
   Momus
 
3 - 21.05.20 - 12:13
(2) я обычно делаю через КомпоновщикНастроек.ПолучитьНастройки() и уже там меняю
   Momus
 
4 - 21.05.20 - 12:15
(3) хотя нет, вру...
   Флориан
 
5 - 21.05.20 - 12:18
http://catalog.mista.ru/public/1185890/

ОтборНастройки = Отчет.КомпоновщикНастроек.Настройки.Отбор;

//Поиск элемента пользовательских настроек по уникальному идентификатору раздела настроек 

ОтборПользовательскиеНастройки = Отчет.КомпоновщикНастроек.ПользовательскиеНастройки.Элементы.Найти(ОтборНастройки.ИдентификаторПользовательскойНастройки);
ОтборПоСкладу = Неопределено;
ПолеКомпоновкиСклад = Новый ПолеКомпоновкиДанных("Склад");

//Поиск еже созданного ранее элемента отбора    

Для каждого ЭлементОтбора Из ОтборПользовательскиеНастройки.Элементы Цикл
   Если ТипЗнч(ЭлементОтбора) = Тип("ЭлементОтбораКомпоновкиДанных")
             и ЭлементОтбора.ЛевоеЗначение = ПолеКомпоновкиСклад Тогда
      ОтборПоСкладу = ЭлементОтбора;
      Прервать;
   КонецЕсли;    
КонецЦикла;

ОтборПоСкладу.Использование = Истина;
   Momus
 
6 - 21.05.20 - 12:23
(5) в (2) "Пользовательские настройки не содержат в себе записей"
   Cоляпсус
 
7 - 21.05.20 - 12:37
(5) Не работает.
https://prnt.sc/skynnj
   Флориан
 
8 - 21.05.20 - 12:43
(7) я правильно понимаю что пользовательские настройки - это в обычном режиме которые заданы пользователем, а "настройки" - это задано в конфигураторе? Тогда "настройки" копируй в "пользовательские" открывай отчет с помощью "пользовательских" и потом уже в "пользовательских" меняй использование
   Cоляпсус
 
9 - 21.05.20 - 12:55
(8) а напрямую это не работает? Отчёт открывается с пустой настройкой, пользователь выбирает например Поставщика, потом решил удалить его и снова сформировать отчёт. Вот тут и казус, что на форме поле очищается, а в настройках отбор остаётся. И не могу от этого избавиться. Можно даже не удалять отбор, а просто снять галку, но вот и она никак не хочет сниматься, использование истина в ложь никак не превращается
   Флориан
 
10 - 21.05.20 - 13:32
(9) >> на форме поле очищается - так выведи на форму и флаг использования отбора

http://catalog.mista.ru/public/1090513/

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.