Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Значение не является значением объектного типа (Год)

Значение не является значением объектного типа (Год)
Я
   FrostBite101
 
17.05.20 - 15:02
Хотел вывести все дерево значений, но что-то ругается. Не могу понять.

&НаСервере
Процедура Вывод()


    Дерево = Новый ДеревоЗначений;
    Дерево.Колонки.Добавить("Год");
    Дерево.Колонки.Добавить("Месяц");
    Дерево.Колонки.Добавить("Градусы");
    
    Строка = Дерево.Строки.Добавить();
    Строка.Год = 2015;
    Строка.Месяц = "Все месяцы";
    Строка.Градусы = 100;
    
    Подстрока = Строка.Строки.Добавить();
    Подстрока.Год = 2015;
    Подстрока.Месяц = "Первый";
    Подстрока.Градусы = 15;
    
    
    
    
    Строка = Дерево.Строки.Добавить();
    Строка.Год = 2017;
    Строка.Месяц = "Все месяцы";
    Строка.Градусы = 5;
    
    Подстрока =  Строка.Строки.Добавить();
    Подстрока.Год = 2017;
    Подстрока.Месяц = "Пятый";
    Подстрока.Градусы = 30;

    
    
    ЗначениеВДанныеФормы(Дерево,Реквизит1);
    Рекурсия(Дерево.Строки);


КонецПроцедуры


&НаСервере
Процедура Рекурсия(СтрокиТаб)

    Для Каждого Строка Из СтрокиТаб Цикл
        Сообщить(Строка(Строка.Год)+Строка.Месяц+Строка(Строка.Градусы));
        Рекурсия(Строка.Строки);
    КонецЦикла;

КонецПроцедуры
   ДенисЧ
 
1 - 17.05.20 - 15:50
А отладчик отменили уже?
   ДедМорроз
 
2 - 17.05.20 - 19:00
Попробуй вместо строка использовать другое имя.
   hhhh
 
3 - 17.05.20 - 21:21
(0) наверно
   ЗначениеВДанныеФормы(Дерево,Реквизит1); 

в Реквизит1 забыл добавить колонку "Год". Эти 2 дерева должны идеально совпадать по колонкам

Список тем форума
Рекламное место пустует  Рекламное место пустует
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.