Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Событие ПриНачалеРедактирования

Событие ПриНачалеРедактирования
Я
   flcy
 
16.05.20 - 19:01
Добрый день!
Вообщем вопрос такой. Есть событие ПриНачалеРедактирования, есть процедура автозаполнения табличной части

&НаСервере
Процедура АвтоЗаполнениеДанных()         
    Для Каждого ТекущаяСтрока ИЗ ТабЗ Цикл         
        ТекущаяСтрока.Важность = Перечисления.ВариантыВажностиВзаимодействия.Обычная;
    КонецЦикла
КонецПроцедуры

&НаКлиенте
Процедура ВерсииПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
        Если НоваяСтрока И Не Копирование Тогда
        АвтоЗаполнениеДанных();
        КонецЕсли;
КонецПроцедуры  

Вопрос такой, при попытки добавить новую строку, он меняет предыдущую строку на данные которые в процедуре, а нужно автозаполнение только при создании новой строки
   acht
 
1 - 16.05.20 - 19:13
Предпоследний абзац в синтакс-помощнике, перед "использование в версии"
   acht
 
2 - 16.05.20 - 19:23
И кстати 
>  он меняет предыдущую строку на данные которые в процедуре
Это ровно то, что ты запрограммировал - поменять данные во всех строках, включая "предыдущую"
   acht
 
3 - 16.05.20 - 19:25
А, не, судя по "ВерсииПриНачалеРедактирования" у тебя таблица "Версии" называется
   vicof
 
4 - 16.05.20 - 22:16
Автозаполнениеданных переписать, используя текущие данные строки без цикла.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.