Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Параметры СКД на форме внешнего отчета

Параметры СКД на форме внешнего отчета
Я
   Масянька
 
15.05.20 - 09:21
День добрый!
Вводные: платформа 8.2.15.318, обычные формы. Есть отчет (написан не мной). Используется СКД.
Для моей задачи нужно было ввести новый параметр (дата среза РС). Этот параметр вруную задавать не нужно, поэтому в настройках в параметрах СКД убрала, но...
На форме отчета есть ПанельПользователяГоризонтальная, в ней появился этот параметр и убрать не могу.
Подскажите - как?
На скрине: синим - то, что было изначально и должно остаться, красным - новый параметр, которого быть не должно.
https://cdn1.savepice.ru/uploads/2020/5/15/3225240156d1c3bf31cc7f3087369216-full.jpg
Спасибо.
   toypaul
 
1 - 15.05.20 - 09:24
Во 1х ограничить на закладке Параметры доступность пользователю для этого параметра
   toypaul
 
2 - 15.05.20 - 09:25
во 2х, а кто ж его знает как в этом "написанном кем-то" отчете да еще и в ОФ параметры на эту панель добавляются. телепаты только на канале ТНТ
   toypaul
 
3 - 15.05.20 - 09:26
в 3х, убрать его из пользовательских настроек, если по какой-то непонятной причине "кто-то" его туда добавил
   Масянька
 
4 - 15.05.20 - 09:27
(1) https://cdn1.savepice.ru/uploads/2020/5/15/b1f7eebdb6094902fdee1739e8e48a45-full.jpg - самый первый.
Включать в доступные поля - не меняется ничего.
   Масянька
 
5 - 15.05.20 - 09:28
(2) По коду - нигде не нашла названия этой панели.
ПриОткрытии (весь код):
    ТиповыеОтчеты.ОбновитьТаблицуДоступныхНастроекПользователю(ЭтотОбъект);
    ТиповыеОтчеты.УстановитьВариантПоУмолчанию(ЭтотОбъект, ЭтаФорма);
    
    // Нарисуем кнопки выбора настроек на верхней панели

    ТиповыеОтчеты.ОбновитьКнопкиВыбораНастроек(ЭтаФорма, ЭтотОбъект, ПредставлениеНастройки, РежимРедактированияНастройки);
    ТиповыеОтчеты.ОбновитьФормуТиповогоОтчетаПоКомпоновщику(ЭтотОбъект, ЭтаФорма);
    ТиповыеОтчеты.УстановитьВидимостьПанелиВариантовПоУмолчанию(ЭтотОбъект, ЭтаФорма);
    ТиповыеОтчеты.УстановитьВидимостьПанелиПользователяПоУмолчанию(ЭтотОбъект, ЭтаФорма);
    ТиповыеОтчеты.ВосстановитьНастройкиФормыОтчета(ЭтотОбъект, ЭтаФорма);
    ТиповыеОтчеты.УправлениеОтображениемПанелиВариантов(ЭтаФорма);
    ТиповыеОтчеты.УправлениеОтображениемПанелиПользователя(ЭтаФорма);
   Масянька
 
6 - 15.05.20 - 09:29
(3) https://cdn1.savepice.ru/uploads/2020/5/15/19e67677bccb33e768828255e546273d-full.jpg - самое первое, что проверила.
   Масянька
 
7 - 15.05.20 - 09:30
В пользовательском режиме: нет в параметрах, есть только в этой долбаной панели.
   toypaul
 
8 - 15.05.20 - 09:30
(5) надо лучше искать. потом тут рассказать. и какая конфа? может заглянут в тему братья по несчастью.
   toypaul
 
9 - 15.05.20 - 09:32
как плохая идея - грохнуть эту панель. может что-то сломается и в этом поломанном месте и искать причину
   toypaul
 
10 - 15.05.20 - 09:32
ну или закоментить все эти вызовы. по очереди
   Масянька
 
11 - 15.05.20 - 09:32
(8) УПП 8.1.10.17
   Масянька
 
12 - 15.05.20 - 09:32
(9) Ничего не ломается.
   Масянька
 
13 - 15.05.20 - 09:35
Исчезает, если отключить Период (в параметрах).
   Cyberhawk
 
14 - 15.05.20 - 09:39
(4) В СКД две вкладки "Параметры". Ты не в той делаешь.
   Масянька
 
15 - 15.05.20 - 09:40
(14) А в какой надо?
   Cyberhawk
 
16 - 15.05.20 - 09:41
(15) В настройках структуры (последняя вкладка в редакторе СКД) у корня "Отчет". Там ПКМ - свойства пользовательских настроек - найдешь флажок.
   Масянька
 
17 - 15.05.20 - 09:42
   SleepyHead
 
18 - 15.05.20 - 09:43
   SleepyHead
 
19 - 15.05.20 - 09:43
(17) Не там, делай как в 18
   Масянька
 
20 - 15.05.20 - 09:44
   SleepyHead
 
21 - 15.05.20 - 09:45
Установи флажок "Ограничение доступности", и параметр не будет виден пользователю в любом варианте отчета. Но при этом он будет доступен в схеме для работы.
   Cyberhawk
 
22 - 15.05.20 - 09:45
(20) ПКМ не там жмешь. Учитывай (14).
   Масянька
 
23 - 15.05.20 - 09:45
(21) НЕ РАБОТАЕТ!!!!! :(((((((((((((((((((((((((((((((
   SleepyHead
 
24 - 15.05.20 - 09:46
(16) Или я не понял задачу в (0), или ты ее троллишь ))
   SleepyHead
 
25 - 15.05.20 - 09:46
(23) Возможно, я не понял задачу, описанную в (0). Но у меня в отчетах работает.
   Масянька
 
26 - 15.05.20 - 09:47
(22) Последняя вкладка, у корня "Отчет"
   Масянька
 
27 - 15.05.20 - 09:47
(25) У меня тоже работает, если писать новый.
Здесь, судя по всему, где-то сохраняется, а где - ХЗ...
   Cyberhawk
 
28 - 15.05.20 - 09:48
(26) Я нигде не писал, что ПКМ надо по корню делать.
   Cyberhawk
 
29 - 15.05.20 - 09:50
На корень надо встать, чтоб искомая вкладка стала видна
   Масянька
 
30 - 15.05.20 - 09:55
 
 Рекламное место пустует
   toypaul
 
31 - 15.05.20 - 09:58
(13) кто-то не умеет "готовить" СКД :) так это и есть период, а не твоя отключенная ДатаСреза
   Cyberhawk
 
32 - 15.05.20 - 10:04
   Масянька
 
33 - 15.05.20 - 10:34
Я продолжу...
Подмастерьям поваров надо же учиться...
Процедура ОбновлениеОтображения() Экспорт
    
    Если ПанельНастроекНарисована <> Истина И Не Модифицированность Тогда
        
        // Инициализация компоновщиков настроек и, если необходимо, загрузка настроек по умолчанию

        ЗагружатьНастройкиПоУмолчанию = Не РежимРедактированияНастройки И Не ЭтоОтработкаРасшифровки И СохраненнаяНастройка.Пустая();
        Схема = ТиповыеОтчеты.ИнициализироватьКомпоновщикНастроек(ЭтотОбъект, , ЗагружатьНастройкиПоУмолчанию);
        КомпоновщикНастроекПользователя.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(Схема));
        //

        Если Не ЭтоОтработкаРасшифровки И Не РежимРедактированияНастройки Тогда
            ПрименитьНастройку();
            ТиповыеОтчеты.ПрименитьНастройкуПользователяНастройкиОтчета(ЭтотОбъект);
            //ТиповыеОтчеты.ОбработкаФормыПослеПримененияНастройки(ЭтотОбъект, ЭтаФорма);

        Иначе
            // Отработаем изменение отображение панели настроек

            ТиповыеОтчеты.УправлениеОтображениемЭлементовФормыТиповогоОтчета(ЭтотОбъект, ЭтаФорма);
            ТиповыеОтчеты.ПерерисоватьПанельНастроек(ЭтотОбъект, ЭтаФорма, );
            
        КонецЕсли;
        
        ПанельНастроекНарисована = Истина;
        
    КонецЕсли;
    ТиповыеОтчеты.ОбновитьЗаголовокТиповогоОтчета(ЭтотОбъект, ЭтаФорма);
    
КонецПроцедуры

Вот эта строчка -//ТиповыеОтчеты.ОбработкаФормыПослеПримененияНастройки(ЭтотОбъект, ЭтаФорма); - если заремить нет никаких настроек (абсолютно). Если разремить -появляются настройки (все + панель пользователя).
Как изменить сохраненную настройку?
   Масянька
 
34 - 15.05.20 - 12:26
Вот эта строчка:
ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.РаботникиОрганизации.СрезПоследних(&ДатаСреза) КАК РаботникиОрганизацииСрезПоследних
дает Период в параметрах.
Вариант избавиться от него (Периода)?
   Масянька
 
35 - 15.05.20 - 13:28
Что, никто не умеет готовить? Такую простую вещь...
   toypaul
 
36 - 15.05.20 - 13:29
СрезПоследних({&ДатаСреза})
   toypaul
 
37 - 15.05.20 - 13:31
предлагаю прочитать http://catalog.mista.ru/public/1219807/
там в том числе про это есть
   Масянька
 
38 - 15.05.20 - 13:33
(36) Спасибо огромное!
(37) У меня книжка Хрусталевой по СКД, а там нету. Спасибо!


Список тем форума
Рекламное место пустует  Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.