Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка процедура или функция с указанным именем не определена

Ошибка процедура или функция с указанным именем не определена
Я
   Коржик 17
 
12.05.20 - 16:04
Нужно при проведении документа "Ввод косвенных расходов" должны появляться записи в регистре  "Косвенные расходы". Период в регистре имеет тип Дата реквизиты месяц и год в документе нужно перевести в дату формат дата.месяц.год Но показывает ошибку процедура или функция с указанным именем не определена строка ПолучитьПериодРасхода
Процедура ОбработкаПроведения(Отказ, Режим)
    //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

    // регистр КосвенныеРасходы
               Движения.КосвенныеРасходы.Записывать = Истина;
    ПериодРасхода = ПолучитьПериодРасхода (Месяц,ГОД);

    Для Каждого ТекСтрокаТабличнаяЧасть2 Из ТабличнаяЧасть2 Цикл
        Движение = Движения.КосвенныеРасходы.Добавить();
        Движение.Период = ПериодРасхода;
        Движение.СтатьиРасходов = ТекСтрокаТабличнаяЧасть2.СтатьиРасходов;
        Движение.Сумма = ТекСтрокаТабличнаяЧасть2.Сумма;
        КонецЦикла;

    //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
        КонецПроцедуры

Функция ПолучитьПериодРасход(Месяц,Год)
    Если Месяц=Перечисления.Месяц.январь Тогда
        МесяцВВидеЧисла=01
    ИначеЕсли Месяц=Перечисления.Месяц.февраль Тогда
        МесяцВВидеЧисла=02
                       ИначеЕсли Месяц=Перечисления.Месяц.март Тогда
        МесяцВВидеЧисла=03
                ИначеЕсли Месяц=Перечисления.Месяц.апрель Тогда
        МесяцВВидеЧисла=04
                ИначеЕсли Месяц=Перечисления.Месяц.май Тогда
        МесяцВВидеЧисла=05
                  ИначеЕсли Месяц=Перечисления.Месяц.июнь Тогда
        МесяцВВидеЧисла=06
                  ИначеЕсли Месяц=Перечисления.Месяц.июль Тогда
        МесяцВВидеЧисла=07
                           ИначеЕсли Месяц=Перечисления.Месяц.август Тогда
        МесяцВВидеЧисла=08
                  ИначеЕсли Месяц=Перечисления.Месяц.сентябрь Тогда
        МесяцВВидеЧисла=09
          ИначеЕсли Месяц=Перечисления.Месяц.октябрь Тогда
        МесяцВВидеЧисла=10
            ИначеЕсли Месяц=Перечисления.Месяц.ноябрь Тогда
        МесяцВВидеЧисла=11
                ИначеЕсли Месяц=Перечисления.Месяц.декабрь Тогда
        МесяцВВидеЧисла=12
        КонецЕсли;
                  
        Возврат Дата(Строка(Год),МесяцВВидеЧисла,01,00,00,00);
    
    КонецФункции
   Fedor-1971
 
1 - 12.05.20 - 16:06
(0) поставь в начало модуля:
Функция ПолучитьПериодРасход(Месяц,Год) Далее
   Волшебник
 
Модератор
2 - 12.05.20 - 16:08
ПолучитьПериодРасхода <> ПолучитьПериодРасход

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.