Вход | Регистрация
 

Сохранение параметров отчета для пользователя

Сохранение параметров отчета для пользователя
Я
   Emiliya_Emili
 
11.05.20 - 14:18
Добрый день, подскажите как сохранять для каждого пользователя настройки параметров (такие как период, организация и другие) отчета?
   Волшебник
 
1 - 11.05.20 - 15:32
в регистре сведений
   Emiliya_Emili
 
2 - 11.05.20 - 15:42
(1) в каком?
и как это прописать кодом?
   ДенисЧ
 
3 - 11.05.20 - 15:45
(2) открой лююой классическю типовую - там это есть.
Зачем изобретать коня с педалями?
   Emiliya_Emili
 
4 - 11.05.20 - 15:55
(3) а это сработает для внешнего отчета?
   Волшебник
 
5 - 11.05.20 - 15:57
(2) в регистре СохранённыеНастройки
   Emiliya_Emili
 
6 - 11.05.20 - 16:06
Пробовала этот метод, но данные не сохраняются
Процедура ПриЗакрытии()
    //ФормаПриЗакрытии(ЭтотОбъект, ЭтотОбъект, ЭтаФорма); 

    
    //Сохранение поля типа дата 

    СохранитьЗначение("НачалоПериода",  НачалоПериода);    
    СохранитьЗначение("КонецПериода",  КонецПериода);    
КонецПроцедуры

Процедура ПриОткрытии()
  //ФормаПриОткрытии(ЭтотОбъект, ЭтотОбъект, ЭтаФорма);

   
    //Получаем значения сохраненных параметров

    НачалоПериода = ВосстановитьЗначение("НачалоПериода");
    КонецПериода = ВосстановитьЗначение("КонецПериода");
    //Восстанавливаем значения через вспомогательную процедуру с проверкой типа 

    //и возвращаемого значения

    УстановитьЗначение(НачалоПериода, НачалоПериода);
    УстановитьЗначение(КонецПериода, КонецПериода);
КонецПроцедуры

Процедура УстановитьЗначение(СохраненноеЗначение, Значение)
    
    Если СохраненноеЗначение <> Неопределено Тогда
        Если Типзнч(СохраненноеЗначение) = Тип("ТаблицаЗначений") Тогда
            Значение.Загрузить(СохраненноеЗначение);
        Иначе    
            Значение = СохраненноеЗначение;
        КонецЕсли;    
    КонецЕсли;
    
КонецПроцедуры
   Волшебник
 
7 - 11.05.20 - 16:21
Регистр надёжнее
   Chameleon1980
 
8 - 12.05.20 - 05:05
(6) сохранитьзначение доступность, вроде только в толстом
   Emiliya_Emili
 
9 - 12.05.20 - 08:08
(7) а что прописать чтобы сохранение настроек работало?
   Ненавижу 1С
 
10 - 12.05.20 - 08:17
в типовых конфигурациях уже все есть, механизм разный - зависит от конфигурации
   Emiliya_Emili
 
11 - 12.05.20 - 08:23
(10) а где эти механизмы можно посмотреть? 1с:усо
   ам794123
 
12 - 12.05.20 - 08:26
(0) у формы есть свойство Автоматическое сохранение данных формы в настройках. устанавливаем его в значений использовать, помечаем какие данные сохранять и все.
   Ненавижу 1С
 
13 - 12.05.20 - 08:27
(11) в коде, либо есть РС СохраненныеНастройки, либо есть справочник ВариантыОтчетов
   vicof
 
14 - 12.05.20 - 08:40
   Emiliya_Emili
 
15 - 12.05.20 - 08:58
(12) а где это? через контекстное меню его нету
   hhhh
 
16 - 12.05.20 - 09:29
(15) в свойствах формы смотри. Галочка сохранять
   Emiliya_Emili
 
17 - 12.05.20 - 12:56
(16) установила, но после закрытия внешнего отчета и его повторного открытия данные теряются
   hhhh
 
18 - 12.05.20 - 13:42
(17) ну не у всех реквизитов значит галочку сохранять поставили. проверьте реквизиты

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.