Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Сравнение значений 1С 8.3

Сравнение значений 1С 8.3
Я
   Dersus
 
06.05.20 - 06:30
Как мне взять значение из "РежимЗаписи" и сравнить не равно ли оно "Проведение"?
Саму структуру "РежимЗаписи" я получил, а вот как сравнить её значение не могу понять.
   Dersus
 
1 - 06.05.20 - 07:12
Мне нужно проверить в обработке "перед записью", имеет ли РежимЗаписи значение "Проведение" или нет.
   МимохожийОднако
 
2 - 06.05.20 - 07:16
Не надо стесняться. Снимай покров со своего кода.
   Галахад
 
3 - 06.05.20 - 07:36
РежимЗаписи = РежимЗаписиДокумента.Проведение
   Dersus
 
4 - 06.05.20 - 08:01
(3) Не работает
   Василий Алибабаевич
 
5 - 06.05.20 - 08:04
(4) ГЫ. И вот так вот...
А в чем выражается "не работает" - догадайся сам. Может оно кофе херово заваривает... А может еще чего.
Хотя в (3) код 100 пудово проверяющий РежимЗаписи.
   Dersus
 
6 - 06.05.20 - 08:06
(5) Если РежимЗаписи = РежимЗаписиДокумента.Проведение Тогда    
      .....
    КонецЕсли;

Он сравнивает и выходит из условия, хотя через отладку Значение режима записи = проведение
   Галахад
 
7 - 06.05.20 - 08:15
(6) Куда выходит?
   Василий Алибабаевич
 
8 - 06.05.20 - 08:16
(6) Давай по порядку.
Вот это вот : "Если РежимЗаписи" в управляемом приложении, в модуле объекта ВСЕГДА даст ЛОЖЬ. Потому что в УП "РежимЗаписи" есть членом коллекции ПараметрыЗаписи. И при проверкек нему нужно обращаться как к члену коллекции.
ДляНапример :
Если ПараметрыЗаписи.Свойство("РежимЗаписи") Тогда
  Если ПараметрыЗаписи.РежимЗаписи = РежимЗаписиДокумента.Проведение Тогда
    ...
  КонецЕсли;
КонецЕсли;
   Ц_У
 
9 - 06.05.20 - 08:46
(7) навеяло :)
Диалог между юношей и Ээхом

Это я, добрый Э-эх, я здесь.
И я здесь!
А ты кто такой, откуда взялся?
С того берега моря.
На чём приехал?
Оседлал хромую блоху, сел и приехал.
Море что, лужа?
Может, и лужа, да только ту лужу орёл не перелетел.
Значит, орёл — птенец?
Наверное, птенец, но тень от его крыльев город закрывает, в городе ночь настаёт.
Город, небось, крохотный?
Через тот город заяц бежал, не перебежал.
Выходит, заяц маленький?
Заяц как заяц, из его шкуры тулуп вышел.
Куда вышел?
Вышел из того города, где заяц бежал, на который тень от орла упала, и пошёл куда глаза глядят.
Чьи глаза?
Глаза того тулупа, который из шкуры зайца вышел, в городе где ночь настаёт, когда над ним птенец пролетает верхом на хромой блохе.
Чего?!
Чего-чего, на хромой блохе с того берега моря, которое зайцу не перелететь, орлу не перебежать, хоть море не море, а так, лужа посреди города, где тень от блохи на зайца упала и насмерть убила, а из шкуры зайца тулуп вышел и пошёл куда глаза глядят, а тут заяц ка-ак прыгнет!..
Какой заяц?!
Насмерть убитый, как прыгнет куда глаза глядят — аж на тот берег моря, которое ни перелететь, ни перебежать, из которого тулуп вышел, на который тень от блохи упала и зайца убила, хоть заяц — не заяц, а орёл…
Какой заяц, какой орёл, какая блоха?!
Так повторить? Ну, значит, та самая блоха с того берега лужи…
А-а-а-а-а!!! Да хватит!!! О-ой!!!
Эй! Погоди! Далеко ещё до рассвета!
   Ненавижу 1С
 
10 - 06.05.20 - 08:54
(8) ты не путай пожалуйста, в событиях форм РежимЗаписи вообще нет параметра
а в событиях объекта - есть
   Василий Алибабаевич
 
11 - 06.05.20 - 09:06
(10) В (0) - "Саму структуру "РежимЗаписи" я получил".
Так что ИМХО, ТС сравнивает РежимЗаписи там, где оно существует.
   Ненавижу 1С
 
12 - 06.05.20 - 09:20
(11) я отвечал на (8), что понимает ТС под "структурой" РежимЗаписи я не знаю
РежимЗаписи имеет тип системного перечисления, а не структуры
   Василий Алибабаевич
 
13 - 06.05.20 - 09:25
(12) Ну правильно. "РежимЗаписи имеет тип системного перечисления, а не структуры".
Но! Само лежит в структуре ПараметрыЗаписи. А в (0) ТС обращается к нему не как члену структурі, а как к одиночному значеию. Вот что я имел ввиду.
   Ненавижу 1С
 
14 - 06.05.20 - 09:28
(13) невсегда оно лежит в структуре
в событиях объекта оно лежит само по себе как параметр события

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.