Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Печать номеров счет-фактур без префикса,но с нулями БП 3.0

Печать номеров счет-фактур без префикса,но с нулями БП 3.0
Я
   Sveta784
 
26.04.20 - 15:18
Добрый день,
сделали переход с 7ки на 8ку,
в 8ке все счет-фактуры печатались с нулями и попадали в книгу покупок тоже с нулями (например 00000015).
а в БП 3.0 без нулей ( например 15), как сделать так чтобы тоже с нулями попадало в книгу покупок?
   kubik_live
 
1 - 26.04.20 - 15:28
После перехода нумерацию СчФ с 1-й начали?
   Sveta784
 
2 - 26.04.20 - 17:43
Да. первая счет фактура в этом году номер 0000000001. еще написала книга покупок, так как туда с ф на аванс попадают, а так,конечно,книга продаж
   Сияющий Асинхраль
 
3 - 26.04.20 - 23:04
Есть в БП модуль "ПрефиксацияОбъектовКлиентСервер", а в этом модуле функция:
Функция НомерНаПечать(Знач НомерОбъекта, УдалитьПрефиксИнформационнойБазы = Ложь, УдалитьПользовательскийПрефикс = Ложь) Экспорт
    
    // {Обработчик: ПриПолученииНомераНаПечать} Начало

    СтандартнаяОбработка = Истина;
    
    ПрефиксацияОбъектовКлиентСерверПереопределяемый.ПриПолученииНомераНаПечать(НомерОбъекта, СтандартнаяОбработка,
        УдалитьПрефиксИнформационнойБазы, УдалитьПользовательскийПрефикс);
    
    Если СтандартнаяОбработка = Ложь Тогда
        Возврат НомерОбъекта;
    КонецЕсли;
    // {Обработчик: ПриПолученииНомераНаПечать} Окончание

    
    НомерОбъекта = СокрЛП(НомерОбъекта);
    
    // Удаляем пользовательские префиксы из номера объекта.

    Если УдалитьПользовательскийПрефикс Тогда
        
        НомерОбъекта = УдалитьПользовательскиеПрефиксыИзНомераОбъекта(НомерОбъекта);
        
    КонецЕсли;
    
    // Удаляем лидирующие нули из номера объекта.

    НомерОбъекта = УдалитьЛидирующиеНулиИзНомераОбъекта(НомерОбъекта);
    
    // Удаляем префикс организации и префикс информационной базы из номера объекта.

    НомерОбъекта = УдалитьПрефиксыИзНомераОбъекта(НомерОбъекта, Истина, УдалитьПрефиксИнформационнойБазы);
    
    Возврат НомерОбъекта;
КонецФункции

Вот, если закоментарить в этой процедурке строчку:

    НомерОбъекта = УдалитьЛидирующиеНулиИзНомераОбъекта(НомерОбъекта);

То лидирующие нули не должны бы удаляться, НО, и это важно номера для записей книг продаж-покупок помнится сохраняются не только в самих документах, но и еще куда-то пишутся, не помню куда, то ли в регистр какой-то то ли в табличную часть какую-то, поэтому эта процедурка сработает только для доков с новыми номерами, а то, что было придется править не только номера документов уже имеющихся, но и номера в этом то ли регистре, то ли табличной части. Иными словами при изменении этой процедурки гемороя и лишних телодвижений удается избежать только в случае, если учет в базе только начинается, если документы уже есть придется вносить большее количество поправок...
   Aleksey
 
4 - 26.04.20 - 23:29
(3) Есть еще регистр Сведения Префиксация объекта. ЕЕ тоже можно лапками пожамкать, иногда очень интересный эффект получается
   Aleksey
 
5 - 26.04.20 - 23:30
Только помоему перезайти в 1С надо, ибо кэш и все дела
   p-soft
 
6 - 27.04.20 - 01:04
есть регистр сведений ДанныеПервичныхДокументов, в нем хранятся номера документов и оттуда номера должны браться по требованию. но в коде есть забавные места..
нормально ситуация лечится только расширением, по схеме как написано в (3), и перезаполнением регистра сведений ДанныеПервичныхДокументов.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.