Вход | Регистрация
 

Шрифт Заголовка Флажка

Шрифт Заголовка Флажка
Я
   Nemirov
 
21.04.20 - 15:36
Не могу найти нормального ответа, при изменении шрифта заголовка флажка
Процедура ПКОПриИзменении(Элемент)
    
    Если ЭлементыФормы.ПКО.Значение = Истина  Тогда
        ЭлементыФормы.РКО.Значение = Ложь;
    КонецЕсли;    
    Если ЭлементыФормы.ПКО.Значение = Ложь Тогда
        ЭлементыФормы.РКО.Значение = Ложь;
    КонецЕсли;
    Если ЭлементыФормы.ПКО.Значение = Истина Тогда
        Элемент.Шрифт.Жирный = Истина
    Иначе    
        Элемент.Шрифт.Жирный = Ложь;
    КонецЕсли;
    
КонецПроцедуры



Выдает ошибку;

{ВнешняяОбработка.ГрупповаяОбработка.Форма.Форма.Форма(33)}: Поле объекта недоступно для записи (Жирный)
        Элемент.Шрифт.Жирный = Истина
Как обойти?
   Nemirov
 
1 - 21.04.20 - 15:37
Необходимо когда Флажок имеет значение истина заголовок был жирным.
   Lex_Liven
 
2 - 21.04.20 - 15:38
Шрифт = Новый Шрифт(<необходимые параметры>);
Элемент.Шрифт = Шрифт;
   Lex_Liven
 
3 - 21.04.20 - 15:39
Читай внимательно Помощник.
Во-первых, он называется Полужирный.
Во-вторых, Шрифт (Font)

Полужирный (Bold)

Использование:
Только чтение.
   Cthulhu
 
4 - 21.04.20 - 17:09
Элемент.Шрифт = Новый Шрифт( Элемент.Шрифт , , , ЭлементыФормы.ПКО.Значение = Истина );

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.