Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как обратиться к реквизиту реквизита?

Как обратиться к реквизиту реквизита?
Я
   Leada
 
12.04.20 - 18:32
Здравствуйте. Я работаю над созданием билетной кассы.
Начну с общего описания:
У меня есть справочник "тит_КатегорияБилета" в нём я указываю наименование билета, цену и тип билета.
В типе билета указывается информация из созданного мной перечисления "тит_Типбилета" экскурсия или входной билет.
Так же есть справочник "тит_Экскурсоводы" где перечисляю экскурсоводов и так же есть вариант "без экскурсовода".
И есть документ "тит_Билет", где в свою очередь есть табличная часть. В табличной части такие реквизиты: КатегорияБилета, Экскурсовод, Цена, Количество, Сумма.

И вот с чем возник вопрос: Как сделать что бы   когда выбиралась категория билета с указанными типом билета "входной билет" в экскурсоводе выставлялось "без экскурсовода"?

Мне подсказали что нужно прописать примерно так:
на сервере
Процедура при изменении
если Объект. реквизитДокумента. реквизитРеквизитаДокумента Тогда и т.д.

Я прописала так:

&НаСервере
Функция ПолучитьТипБилета()
    
    возврат справочники.тит_Экскурсоводы.НайтиПоКоду(000000026);
КонецФункции

&НаСервере
Процедура СоставКатегорияБилетаПриИзмененииНаСервере(Элемент)
    текДанные = Элементы.Состав.ТекущиеДанные;
    Если объект.СоставКатегорияБилета.ТипБилета.ВходнойБилетНесоставной тогда
        Элементы.Состав.ТекущиеДанные.Экскурсовод = справочники.тит_Экскурсоводы.НайтиПоКоду(000000026);
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура СоставКатегорияБилетаПриИзменении(Элемент)
    СоставКатегорияБилетаПриИзмененииНаСервере(Элемент);
КонецПроцедуры
   Leada
 
1 - 12.04.20 - 18:34
Функция ПолучитьТипБилета не нужна
   Ненавижу 1С
 
2 - 12.04.20 - 19:24
интересно мы курсовую пишем
или это уже сразу дипломная?
   H A D G E H O G s
 
3 - 12.04.20 - 19:40
В предыдущей теме автор уточнял, что префикс "тит" от них требует работодатель.
Я и искренне надеюсь, что это курсач или диплом, иначе это реально ЯдерныйТитбит получается.
   Garykom
 
4 - 12.04.20 - 19:49
(0)
1. Что делать если на экскурсии два и более экскурсоводов одновременно?
2. Зачем нужен элемент справочника экскурсоводы "без экскурсовода"?
Не логичнее ли поле оставить пустым и даже запретить выбор/редактирование если "входной билет"
3. Выбирать элементы по коду маразм, есть предопределенные
   Leada
 
5 - 12.04.20 - 20:06
(4) 1. вероятность этого исключина
2. Так потребовал заказчик.
3. Да, это сейчас исправлю.


(2) (3) к сожалению это работа. Пришла на обучение в компанию, думала будут давать материалы для изучения ибо они знали что бирут человека с нуля, но меня сразу на поле битвы отправили)
   Ненавижу 1С
 
6 - 12.04.20 - 20:08
(5) контору в студию!
   tixis
 
7 - 12.04.20 - 20:08
(5)
1 все меняется, сейчас быть не может, а потом может
2 а вы понимаете для чего этот справочник или только Так потребовал заказчик
   Leada
 
8 - 12.04.20 - 20:10
(7) я уточнала этот момент у заказчика.
2. я то понимаю и им объясняла, но им нужно что бы им в таблицу подставлялось "без экскурсовода"
   HawkEye
 
9 - 12.04.20 - 20:27
(5) скажи им пусть больше не "бирут" с нуля..
   Garykom
 
10 - 12.04.20 - 20:29
(8) >2. я то понимаю и им объясняла, но им нужно что бы им в таблицу подставлялось "без экскурсовода"

Сделай через условное оформление чтобы если не выбран/пустое то выводилось "без экскурсовода"
   Garykom
 
11 - 12.04.20 - 20:31
(9) А не с нуля стоят слишком дорого, у них столько денег нет
   zladenuw
 
12 - 12.04.20 - 20:44
1. Без экскурсовода. сделай предопределенным элементом. и его вызывай по коду.
2. в нете куча инфы про стар для 1с.
   Leada
 
13 - 12.04.20 - 23:06
(12) Помогите пожалуйста сейчас с этой задачкой разобраться. Хотя бы начало. Дальше может сама додумаю
   hhhh
 
14 - 12.04.20 - 23:08
(13) попробуйте кавычки туда зафигачить, "000000026"

Список тем форума
Рекламное место пустует  Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.