Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как правильно прописать условие?

Как правильно прописать условие?
Я
   Leada
 
10.04.20 - 17:12
Здравствуйте. Я работаю над созданием билетной кассы.
Начну с общего описания:
У меня есть справочник "тит_КатегорияБилета" в нём я указываю наименование билета, цену и тип билета.
В типе билета указывается информация из созданного мной перечисления "тит_Типбилета" экскурсия или входной билет.
Так же есть справочник "тит_Экскурсоводы" где перечисляю экскурсоводов и так же есть вариант "без экскурсовода".
И есть документ "тит_Билет", где в свою очередь есть табличная часть. В табличной части такие реквизиты: КатегорияБилета, Экскурсовод, Цена, Количество, Сумма.

И вот с чем возник вопрос: Как сделать что бы   когда выбиралась категория билета с указанными типом билета "входной билет" в экскурсоводе выставлялось "без экскурсовода"?
   Cyberhawk
 
1 - 10.04.20 - 17:13
Глядя на префикс, сразу приходит на ум https://ru.wikipedia.org/wiki/Ядерный_титбит
   ejikbeznojek
 
2 - 10.04.20 - 17:16
Чем не устраивает предыдущая тема?
Как правильно прописать условие?
   Leada
 
3 - 10.04.20 - 17:18
(1) это работадатель требует, что бы мы так писали, что бы знать где была работа сделана нами.
(2) по итогу там не очень понятно было и больше мне никто не отвечал, решила новую создать.
   МимохожийОднако
 
4 - 10.04.20 - 17:19
(3) Если никто не отвечает... терпи и думай.)
   Leada
 
5 - 10.04.20 - 17:22
(4) Я уже со вчерашнего дня терплю и думаю, мозгов не хватает пока что для решения таких задачек))
   Leada
 
6 - 10.04.20 - 17:26
(4) Я конечно умею условия прописывать, но мне не совсем понятны детали.
как то так:
&НаСервере
Функция ПолучитьБезЭкскурсовода()
    
    возврат справочники.тит_Экскурсоводы.НайтиПоКоду(000000026);
КонецФункции

&НаСервере
Процедура СоставКатегорияБилетаПриИзменении(Элемент)
ТекДанные = Элементы.Состав.ТекущиеДанные;
если ТекДанные.КатегорияБилета = <не знаю как прописать, так что бы он понял что речь идёт про тип билета> тогда
ТекДанные.Экскурсовод = ПолучитьБезЭкскурсовода();
КонецЕсли
КонецПроцедуры
   Leada
 
7 - 10.04.20 - 17:27
Ой там процедура на клиенте должна быть

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.