Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не публикуется база 1С на веб-сервере

Не публикуется база 1С на веб-сервере
Я
   igor-kopakov
 
07.04.20 - 11:12
Добрый день!

Версия 1С:Предприятие 8.3 (8.3.13.1690)
Конфигурация: BAS Управління торгівлею, редакція 3.2 (3.2.13.2)

При первоначальной настройке конфигурации и публикации её на веб-сервере Apache 2.4 всё работало: база публиковалась, доступ был через интернет.

Спустя несколько месяцев я вернулся к 1С и начал заносить данные для ведения учёта. Решил предоставить доступ своему сотруднику, но уже доступ через интернет не работал. Работал только доступ только через localhost/basa. Я решил обновить публикацию базы, но после этого и через localhost/basa стало недоступно. В папке с базой лишь один файл default.vrd

Если с доступом через интернет понятно, что нужно искать причину в доступах или в портах или ещё в чём-то, по почему не публикуется база, не понимаю.

Публикация на веб-сервер https://pastenow.ru/98e4c78d9d590ffa78c065105cdef138
Содержимое файла default.vrd  https://pastenow.ru/befeae5096bd47db227f41e6ae27180b
   Garykom
 
1 - 07.04.20 - 11:14
(0) httpd.conf ?
   igor-kopakov
 
2 - 07.04.20 - 11:27
Ссылка на httpd.conf  https://drive.google.com/open?id=1K4EwAI9EUdT3WKNL5mJJNM12A-JK55CH

В первом скрине не правильный путь к публикации на веб-сервере https://pastenow.ru/f3e1f92ce9efb7caf643859db5c1bfa9
   spiller26
 
3 - 07.04.20 - 11:58
(0) А что у вас два Alias "/FLPKopakov" прописано?
   spiller26
 
4 - 07.04.20 - 12:06
Доступ к папке где лежит "default.vrd" есть?
   Garykom
 
5 - 07.04.20 - 12:31
(2) Апач у тебя как служба? Перезапусти и проверь что стартанет.
   igor-kopakov
 
6 - 07.04.20 - 13:29
(3) Даже не знаю почему. Если я все Alias вручную с файла удалю и по новой опубликую базу, это поможет?
   igor-kopakov
 
7 - 07.04.20 - 13:34
(5) Спасибо! Перезагрузка помогла. Доступ по http://localhost/kopflp2/ru_UA/ появился.

Доступ по внешнему IP перекидывает в админку роутера https://pastenow.ru/c376f80756a615bbee1ebdb9da8fed6c
   igor-kopakov
 
8 - 07.04.20 - 16:12
По внешнему IP уже есть подключение, только выдаёт 404 Not Found https://pastenow.ru/e97b231a8eaf7e9362a7ee515a562055

Подскажите, может я в настройках публикации на веб-сервер что-то не включил
   Василий Алибабаевич
 
9 - 07.04.20 - 17:16
(8) 80-й порт нужно пробросить через роутер на внутренний ip твоего апача.
   igor-kopakov
 
10 - 07.04.20 - 17:33
(9) Спасибо! Был неправильно порт проброшен в роутере.

Всем большое спасибо за уделённое время!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.