Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Передать таблицу значений в обработку заполнения

Передать таблицу значений в обработку заполнения
Я
   geminisf
 
04.04.20 - 08:54
Доброго всем дня. Есть таблица значений с товарами. И есть вот такая обработка заполнения:

Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
    Если ДанныеЗаполнения <> Неопределено И
        ТипЗнч(ДанныеЗаполнения) = Тип("Структура") Тогда
        
        Если ДанныеЗаполнения.Свойство("Товары") = Истина Тогда
            Если ЭтоАдресВременногоХранилища(ДанныеЗаполнения.Товары) Тогда
                ДанныеЗаполнения.Товары = ПолучитьИзВременногоХранилища(ДанныеЗаполнения.Товары)
            КонецЕсли;
            
            ЭтотОбъект.Товары.Загрузить(ДанныеЗаполнения.Товары);
        КонецЕсли;     
        Если ДанныеЗаполнения.Свойство("Услуги") = Истина Тогда
            Если ЭтоАдресВременногоХранилища(ДанныеЗаполнения.Услуги) Тогда
                ДанныеЗаполнения.Услуги = ПолучитьИзВременногоХранилища(ДанныеЗаполнения.Услуги)
            КонецЕсли;
            ЭтотОбъект.Услуги.Загрузить(ДанныеЗаполнения.Услуги);
        КонецЕсли;
        ЗаполнитьЦены();
        РассчитатьСуммы();
    КонецЕсли;
КонецПроцедуры


Как правильно передать данные из таблицы значений в обработку?
   geminisf
 
1 - 04.04.20 - 09:16
Всем спасибо. Разобрался.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.