Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

То ли лыжи не едут, то ли я .......

То ли лыжи не едут, то ли я .......
Я
   sirbure
 
23.03.20 - 17:18
Почему я не могу передать с сервера на клиент число преобразованное в строку?
   Fish
 
1 - 23.03.20 - 17:18
Показывай код
   sirbure
 
2 - 23.03.20 - 17:20
Функция АналогиНоменклатураПриИзмененииНаСервере(Номенклатура)
    Номенклатура=Номенклатура.Ссылка.ПолучитьОбъект();
    УТН=Номенклатура.Код;
    УТН=СокрЛП(СтрЗаменить(УТН,"00-",""));
    УТН=СокрЛП(СтрЗаменить(УТН,"ЦБ-",""));
    Возврат Строка(УТН);
    // Вставить содержимое обработчика.

КонецФункции

Ошибка преобразования данных XDTO:
   trad
 
3 - 23.03.20 - 17:21
ошибка наверняка при передаче параметра, а не при возврате
   Жан Пердежон
 
4 - 23.03.20 - 17:21
(0) лыжи едут
   sirbure
 
5 - 23.03.20 - 17:21
именно при возврате
   Chameleon1980
 
6 - 23.03.20 - 17:21
пля, а зачем тут получить обьект?
   SadrArt
 
7 - 23.03.20 - 17:22
(6) + и зачем Строку преобразовывать в строку
   Fish
 
8 - 23.03.20 - 17:23
(5) Потому что ты передал в Функцию ссылку на номенклатуру, а пытаешься вернуть объект.
   Жан Пердежон
 
9 - 23.03.20 - 17:23
(8) выдыхай
   sirbure
 
10 - 23.03.20 - 17:24
Функция ТЕСТ(Номенклатура)
    УТН="999";
    Возврат УТН
КонецФункции
Ошибка преобразования данных XDTO:
Так проще?:)
   sirbure
 
11 - 23.03.20 - 17:25
Функция ТЕСТ(Номенклатура)
    УТН="ааа";
    Возврат УТН
КонецФункции
Все норм
   Fish
 
12 - 23.03.20 - 17:25
+(8) В общем, убери строку 
Номенклатура=Номенклатура.Ссылка.ПолучитьОбъект();

и ошибка уйдёт
   trad
 
13 - 23.03.20 - 17:26
(9) все правильно в (8) говорит
чтобы этот говнокод заработал:
Функция АналогиНоменклатураПриИзмененииНаСервере(Знач Номенклатура)
   Fish
 
14 - 23.03.20 - 17:26
(10) (11) Не верю (с)
   sirbure
 
15 - 23.03.20 - 17:26
(12) это не из за нее,  с объектом мне нужно будет работать....
   Жан Пердежон
 
16 - 23.03.20 - 17:27
(13) он не пытается вернуть объект, он не знает как передача по ссылке работает при клиент/серверном вызове
   Fish
 
17 - 23.03.20 - 17:28
(16) Почему же не пытается? Происходит неявный возврат через значение параметра.
   SadrArt
 
18 - 23.03.20 - 17:28
(15) тогда назови переменную по другому, не совпадающим с параметром
   Жан Пердежон
 
19 - 23.03.20 - 17:28
Возврат СтрЗаменить(СтрЗаменить(Номенклатура.Код,"00-",""),"ЦБ-",""));
   trad
 
20 - 23.03.20 - 17:28
(16) если возвращаемому параметру присваивать объект - это называется "пытается вернуть объект"
   sirbure
 
21 - 23.03.20 - 17:30
(20) где это происходит?
   SadrArt
 
22 - 23.03.20 - 17:32
   Жан Пердежон
 
23 - 23.03.20 - 17:34
(21)
плюс к (22):

Знач
Необязательное ключевое слово, которое указывает на то, что следующий за ним параметр передается по значению, т.е. изменение значения формального параметра при выполнении функции никак не повлияет на фактический параметр, переданный при вызове функции. Если это ключевое слово не указано, то параметр функции передается по ссылке, то есть изменение внутри функции значения формального параметра приведет к изменению значения соответствующего фактического параметра.
   sirbure
 
24 - 23.03.20 - 17:38
Все понял, спс. Чета затупил капец как))


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.