Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Вызов диалога выбора из справочника во время создания документа

Вызов диалога выбора из справочника во время создания документа
Я
   brenli
 
23.03.20 - 08:14
Всем добра.
Переписываю обработку создания документов из нетиповой 1с 7.7 в 1с 8 БП3.0.
В старой обработке загрузки есть такая логика -

                Если СокрП(Контрагент.Наименование) = СокрП(НаимКонтрагента) Тогда
                    Док.Контрагент = Контрагент;                            
                Иначе
                    Если Вопрос("Код - "+ЗагрКод+" в файле - "+НаимКонтрагента+
                        " ,а в справочнике "+Контрагент.Наименование+
                        "Принять ?","Да+Нет")="Нет" Тогда
                        
                    // открыть справочник и подобрать соответствующее значение
                        Если Контрагент.Выбрать("Выберите контрагента","ФормаСписка")>0 Тогда
                            Док.Контрагент = Контрагент;                            
                        КонецЕсли;
                    Иначе
                        Док.Контрагент = Контрагент;                            
                    КонецЕсли;                                    
                КонецЕсли;       
    

Открывает справочник и выбирается необходимый контрагент.
Как грамотно сделать в 1с 8?  Сначала готовим данные для загрузки например в серверном вызове заполняем таблицу данными контрагентов, на клиенте выбираем (проверяем), потом отправляем на сервер?
   Irbis
 
1 - 23.03.20 - 08:20
За Выбрать в цикле — расстрел через повешение без права на УДО.
   brenli
 
2 - 23.03.20 - 08:36
(1) Это фрагмент кода из 1с 7.7 который делал прошлый программист.
Сейчас надо сделать по канонам
   d4rkmesa
 
3 - 23.03.20 - 08:53
(0) Сделайте себе функциональное ТЗ и перепишите "с чистого листа".
   Irbis
 
4 - 23.03.20 - 08:58
Массовая генерация объектов не должна прерываться ничем. То есть ДО её начала все необходимые данные должны быть получены и ПРОВЕРЕНЫ как на валидность так и на непротиворечивость между между собой и с ранее созданными объекатами. каким образом этого достичь — задача оазработчика.
   D_E_S_131
 
5 - 23.03.20 - 11:24
(4) Может им "в кайф" загружать данные в полуручном режиме. :)
   Irbis
 
6 - 23.03.20 - 11:31
(5) В кайф, пусть готовят данные для загрузки, а загружаться всё должно гарантированно и без дурацких вопросов. Или не загружаться с чётким перечнем недостаточной или противоречивой информации.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.