Вход | Регистрация
 

ADODB Закрывает 1с(

ADODB Закрывает 1с(
Я
   Likons
 
20.03.20 - 14:45
Добрый день , Коллеги.
Появилась необходимость получение данных в 1с из сторонней таблички на mysql.
Пробую получить данные следующим образом :

Функция ПодключитсяКSQL()
    
    
   АутентификацияПрошла=Ложь;
    СерверSQL = "localhost";
    БазаSQL = "base";
    ПользовательSQL = "root";
    ПарольSQL = "";
    Connection = Новый COMОбъект("ADODB.Connection");        
    Попытка    
          
        Connection.Open ("DRIVER={MySQL ODBC 5.1 Driver};SERVER="+СерверSQL+";PORT=3306; DATABASE="+БазаSQL+";uid="+ПользовательSQL+";pwd="+ПарольSQL+";");      
    Исключение
            
        сообщить(ОписаниеОшибки());
        возврат 0;            

    КонецПопытки;
    Возврат Connection;    
КонецФункции
Процедура Пример()
    Соединение = ПодключитсяКSQL();
    Если Соединение = 0 тогда
        Сообщить("Все сломалось (");
    КонецЕсли;
    RS = Новый COMОбъект("ADODB.RecordSet");
    RS.Open("SELECT * FROM wp_wc_product_meta_lookup", Соединение);
    
    Пока RS.EOF() = 0 Цикл
        сообщить("фыв");
        RS.MoveNext();  
    КонецЦикла;    
            
  КонецПроцедуры

На этой строчке "RS.MoveNext();" 1c закрывается с сообщением "Подождите пожалуйста , выполняется сохранение информации для последующего анализа", а хотелось бы еще поработать )
Если ее убрать , запрос будто бы отрабатывает.
Буду благодарен за любые соображения по этом поводу )
   ДенисЧ
 
1 - 20.03.20 - 14:48
а если так
RS.Open("SELECT * FROM wp_wc_product_meta_lookup LIMIT 10", Соединение);

?
   Likons
 
2 - 20.03.20 - 14:51
(1) та же картина (
   arsik
 
3 - 20.03.20 - 14:56
МОжет драйвер кривой? возможно у вас там не MySQL а MariaDB
   Likons
 
4 - 20.03.20 - 15:24
(3) залез в phpmyadmin , там mariadb (
Это критично ? Может есть какой общий для них драйвер ? Не подскажите , пожалуйста ?
   arsik
 
5 - 20.03.20 - 15:29
(4) Хз. Скачай да попробуй. https://mariadb.com/kb/en/mariadb-connector-odbc/
   Likons
 
6 - 20.03.20 - 15:42
(5) Спасибо ) Сейчас попробую )

Список тем форума
Рекламное место пустует  Рекламное место пустует
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.