Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Отловить событие добавление пользовательских полей на форму(через изменить форму)

Отловить событие добавление пользовательских полей на форму(через изменить форму)
Я
   Vasilisk
 
18.03.20 - 09:18
Доброго времени суток.

Существует ли возможность отловить событие добавления пользователем полей на управляемую форму через еще/изменить форму? Подойдет событие перерисовки формы, но такового не нашел.
 
 
   butterbean
 
1 - 18.03.20 - 09:19
нафига?
   Vasilisk
 
2 - 18.03.20 - 09:33
(1) Не вежливо отвечать вопросом на вопрос, тем более если этот вопрос, который можно задать на любой вопрос: "Как прыгать на скакалке? Нафига?", "Где найти клад? Нафига?"
   ДенисЧ
 
3 - 18.03.20 - 09:33
(2) А кто Вам сказал, что это невежливо? ))
   Cyberhawk
 
4 - 18.03.20 - 09:44
(2) Ты в позиции просящего, а значит изволь смиренно удовлетворять любопытство любого вопрошающего
   butterbean
 
5 - 18.03.20 - 09:44
(2) тут частенько звучат вопросы типа "как почесать за правым ухом левой пяткой?", и на резонные предложения почесать рукой, начинаются пространные объяснения про производственную необходимость и невозможность другого пути. Вот я заподозрил, что твой вопрос именно из этой серии
   Vasilisk
 
6 - 18.03.20 - 09:51
(5) Сбор статистики по пользователям и УО для добавленных полей.
   Vasilisk
 
7 - 18.03.20 - 09:57
(4) Я ничего не прошу, я лишь спрашиваю, т.е. вопрошающий, согласно вашей логики вы должны удовлетворить любопытство, так где?
   Cyberhawk
 
8 - 18.03.20 - 09:57
(7) Что "где"?
   Vasilisk
 
9 - 18.03.20 - 09:58
(8) Удовлетворение моего любопытства:)
   Cyberhawk
 
10 - 18.03.20 - 10:01
(9) Такие обязательства автоматически накладываются только на авторов веток - вот в чем логика
   Vasilisk
 
11 - 18.03.20 - 10:05
(10) Логики не замечено, замечены двойные стандарты, при этом ответа на прямой вопрос так и не последовало.
   strange2007
 
12 - 18.03.20 - 10:09
"Элементарно, Ватсон" (с)
Обработчик ожидания по которому каждый раз обнюхиваешь форму и все изменения кидаешь куда надо. Если надо для всех форм универсальный механизм, тогда сложнее.
Я бы так сделал.
   butterbean
 
13 - 18.03.20 - 10:10
(12) как обнюхать пользовательскую настройку полей?
   strange2007
 
14 - 18.03.20 - 10:12
(13) "Изменить форму", это значит изменить набор элементов формы. Ну и просматривать их кол-во, названия, состав и т.д.
   МимохожийОднако
 
15 - 18.03.20 - 10:16
(13) Перебирай элементы формы со свойствами и запоминай. При необходимости -перебирай элементы и сравнивай с сохраненными данными.
Но ответь на вопрос " В чем цель статистики?"
   butterbean
 
16 - 18.03.20 - 10:18
(14) разве пользовательские настройки (видимость, заголовок и т.п.) как-то влияют на свойства элемента Видимость, Заголовок и т.п.??
(15) не ко мне вопрос
   Vasilisk
 
17 - 18.03.20 - 10:20
(13) Это не проблема, по крайней мере в моем случае(у меня эти поля в ТЧ), код вот:
Для Каждого ЭлементФормы Из Элементы Цикл
   Если ТипЗнч(ЭлементФормы) = Тип("ПолеФормы") Тогда
    Если СтрЧислоВхождений(ЭлементФормы.ПутьКДанным,".")>1 Тогда 
        //Делаем что-то

    КонецЕсли;
   КонецЕсли;
КонецЦикла;
   Vasilisk
 
18 - 18.03.20 - 10:21
(12) Не годится, излишняя нагрузка.
   Cyberhawk
 
19 - 18.03.20 - 10:21
(11) Замечена подмена понятий: двойной стандарт это про разное отношение к одному и тому же.
Я же вроде довольно наглядно провел черту, отделив вопросы на две категории: от ТСа и от не ТСа.
   МимохожийОднако
 
20 - 18.03.20 - 10:25
(16) Т.е. ты кирпич бросил, а куда и к кому он прилетит "не ко мне вопрос". Любопытная позиция. )
   Vasilisk
 
21 - 18.03.20 - 10:32
(15) (20) Часто добавляемые поля по сути означают некоторый реальный БП, который не описан, соответственно на основании статистики можно сделать один из выводов: БП поставлены не корректно, необходимо провести обучение или решение является не полноценным необходима доработка пользовательского интерфейса.
(19) С вами все понятно, нам не по пути, благодарю за бесполезную участность, больше не надо. (20)
   МимохожийОднако
 
22 - 18.03.20 - 10:38
)))
   Vasilisk
 
23 - 18.03.20 - 10:39
(22) Последнее сообщение относится к вам только в первой части.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.