Вход | Регистрация
 

как можно заставить формироваться отчет СКД в фоне

как можно заставить формироваться отчет СКД в фоне
Я
   inkvizitr
 
17.03.20 - 15:39
как можно заставить формироваться отчет СКД в фоне, есть ли пример?
 
 
   Momus
 
1 - 17.03.20 - 15:41
(0) любой типовой отчет?
   Cyberhawk
 
2 - 17.03.20 - 15:42
В 8.3 это из коробки
   inkvizitr
 
3 - 17.03.20 - 15:43
(1) (2) нет свой самописный, но добавленный в конфигурацию в раздел отчеты, отчет почти полностью формируется программно
   Cyberhawk
 
4 - 17.03.20 - 15:44
Хоть самописный, хоть самосранный - из коробки
   inkvizitr
 
5 - 17.03.20 - 15:45
(4) а можно пример
   inkvizitr
 
6 - 17.03.20 - 15:46
(4) пытался реализовать по этому примеру, но не взлетело http://catalog.mista.ru/public/622567/
   SleepyHead
 
7 - 17.03.20 - 16:37
Если используешь типовую форму отчета - он сразу формируется в фоне.

Если добавил на отчет свою форму - переопределяй кнопку "Сформировать", и в ней запускай метод СкомпоноватьРезультат так, как надо тебе, например так

СкомпоноватьРезультат(РежимКомпоновкиРезультата.Фонововый);
   inkvizitr
 
8 - 17.03.20 - 16:41
(7) я так делал, но при формировании отчета, УФ все равно начинают блокироваться
   SleepyHead
 
9 - 17.03.20 - 16:41
http://1centerprise8.blogspot.com/2016/06/otchet-fonovyj-rezhim.html

Вот неплохая статья на эту тему.
   inkvizitr
 
10 - 17.03.20 - 16:41
и висят песочные часы
   SleepyHead
 
11 - 17.03.20 - 16:42
Тогда не знаю, поищи на инфостарте статьи, возможно, есть решение твоей проблемы.
   uzerp2
 
12 - 17.03.20 - 17:31
асинхронный вызов кода:

1.
сам принцип вот здесь описан:
https://1c-programmer-blog.ru/programmirovanie/sinhronnye-i-asinhronnye-vyzovy-v-1s.html

2.
вот здесь от 1с описание ( но искать замучаешься... )
https://its.1c.ru/docs/v8nonmodal/


===============================================



&НаКлиенте
Процедура АсинхронныеМетоды()
    
    ОбратныйВызов = Новый ОписаниеОповещения("ОбработкаЗавершения", ЭтотОбъект, "доп. параметры", "ОбработкаОшибки", ЭтотОбъект);    
    
    //поищем файлы в папке tmp

    НачатьПоискФайлов(ОбратныйВызов, "D:\tmp", "*.*");
    
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаЗавершения(НайденныеФайлы, ДополнительныеПараметры) Экспорт
    
    //выводим список найденых файлов

    Для Каждого Файл Из НайденныеФайлы Цикл
        Сообщить(Файл.ПолноеИмя);
    КонецЦикла; 
    
    //дополнительный параметр указанный в описании оповещения

    Сообщить(ДополнительныеПараметры);
    
КонецПроцедуры
   inkvizitr
 
13 - 18.03.20 - 09:20
(12) спасибо, сейчас попробую

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.