Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

как вывести поле в отчет без группировки ?

↓ [Fish, 16.03.20 - 14:30]
как вывести поле в отчет без группировки ?
Я
   hshi
 
16.03.20 - 12:57
Всем привет !
Есть запрос  в консоли запросов выводит нормально ЧислоМесяцев договора

В макет это поле выводить не хочет

все остальные поля выводит в макет с группировкой

вопрос почему в макет не выводит поле ?
 
 
   vicof
 
1 - 16.03.20 - 13:08
Потому что консоль запросов и код вывода в макет это разные вещи.
   hshi
 
2 - 16.03.20 - 13:12
(1) это понятно
   hshi
 
3 - 16.03.20 - 13:13
(1) вопрос другой  как поле из запроса вытянуть
   vicof
 
4 - 16.03.20 - 13:14
(3) Также, как ты вытягиваешь другие поля
   hshi
 
5 - 16.03.20 - 13:19
(4) в код не вставлю не сработает код с группировкой .
если отдельно выборку без группировки сделаю то вытяну
   hshi
 
6 - 16.03.20 - 13:30
ОбходРезультатаЗапроса.ПоГруппировкам  это убираю из кода  .поле выводит
   hshi
 
7 - 16.03.20 - 13:41
а у  люди кто поможет ?
   vicof
 
8 - 16.03.20 - 13:51
Ни запроса, ни кода...
   hshi
 
9 - 16.03.20 - 13:54
(8)     ВыборкаДок = ВыборкаКонтр.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
        Пока ВыборкаДок.Следующий() Цикл
            НомерГрафика  =  НомерГрафика + 1;
            
            Если ПараметрыОтчета.ОтборВыбратьПервые Тогда
                Если НомерГрафика > ПараметрыОтчета.ВыбратьПервые Тогда
                    Прервать;
                КонецЕсли;
            КонецЕсли;    

            //Если ВыборкаДок.Остаток <= 0 Тогда

            //    Продолжить;    

            //КонецЕсли;    

            
            Если ПараметрыОтчета.ОтборОстаток И (ВыборкаДок.Остаток <= ПараметрыОтчета.МинОстаток) Тогда
                Продолжить;    
            КонецЕсли;    

            Если ПараметрыОтчета.ОтборВсего И (ВыборкаДок.Всего <= ПараметрыОтчета.МинВсего) Тогда
                Продолжить;    
            КонецЕсли;    
            
            НомерТек = НомерТек+1;
            ОбластьСтрокаОсновной.Параметры.Номер = НомерТек;
            ОбластьСтрокаОсновной.Параметры.Документ = ВыборкаДок.Регистратор;
            ОбластьСтрокаОсновной.Параметры.Контрагент = ВыборкаДок.Регистратор.Контрагент;
            ОбластьСтрокаОсновной1.Параметры.НомерДоговора = ВыборкаДок.Регистратор.Договор.Номер;
            ОбластьСтрокаОсновной1.Параметры.СтоимостьИмущества = ВыборкаДок.Регистратор.СтоимостьИмущества;
            ОбластьСтрокаОсновной1.Параметры.СрокЛизинга=ВыборкаДок.МесяцевДоговора;
   vicof
 
10 - 16.03.20 - 13:59
Половину сделал, молодец
   hshi
 
11 - 16.03.20 - 14:06
(10) молодец слово паразит запомни . ты суть моего вопроса понял или нет?

есть новое поле . в готовы запрос его выбрал

в коде есть куски с группировкой .так вот поле в них не выводит . если группировку убрать по полям то поле выводит в макет
вот ломаю башку .что делать
   vicof
 
12 - 16.03.20 - 14:09
Паразит, ты суть моих уточнений так и не понял. Еще раз 5 прочитай (8).
"вот ломаю башку .что делать"
Увольняться.
   hshi
 
16 - 16.03.20 - 14:12
(12) телепатию развивай
   Йохохо
 
17 - 16.03.20 - 14:16
(13) каких теперь в лизинг берут. вот что удаленка творит)
   hshi
 
18 - 16.03.20 - 14:18
(17) кто тебе про Лизинг шепнул?


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.