Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Из формы внешней обработки открыть другую форму этой обработки и вернуть параметр обратно

Из формы внешней обработки открыть другую форму этой обработки и вернуть параметр обратно
Я
   grumpi
 
16.03.20 - 10:09
Подскажите где затупил из одной формы внешней обработки открываю другую? потом пытаюсь возвратить в исходную параметры, но не срабатывает ОбработкаОповещения в исходной форме

В первой форме такой код:

Процедура ЗаполнитьСтатьиСписания(Команда)
    СтруктураПараметров = ЗаполнитьСписокПараметров();
ОткрытьФорму("ВнешняяОбработка.ЗагрузкаСписанийМатериалов.Форма.ФормаСтатейЗатрат",СтруктураПараметров,Этаформа);
КонецПроцедуры

Процедура ОбработкаОповещения(ИмяСобытия, Параметры, Источник);
    Если ИмяСобытия = "ПеренестиСтатьиЗатрат" Тогда
        ОповещениеНасервере(Параметры);
    КонецЕсли;
КонецПроцедуры

Во второй форме

&НаКлиенте
Процедура Перенести(Команда)
    ИмяСобытия = "ПеренестиСтатьиЗатрат";
    Параметрвызова = ПеренестиНаСервере();
    ФормаИсточник = Этаформа.ВладелецФормы;
    Оповестить(ИмяСобытия,Параметрвызова,ФормаИсточник);
    Закрыть();
КонецПроцедуры
 
 
   grumpi
 
1 - 16.03.20 - 10:13
Прошу прощения за сумбурность, бьюсь уже час.
Из формы внешней обработки открываю другую форму этой же обработки. Форма открывается. Там делаю манипуляции и возвращаю результат в исходную форму.
Но в исходной форме не срабатывает обработка ожидания
   Ц_У
 
2 - 16.03.20 - 10:15
ОткрытьФорму(<ИмяФормы>, <Параметры>, <Владелец>, <Уникальность>, <Окно>, <НавигационнаяСсылка>, <ОписаниеОповещенияОЗакрытии>, <РежимОткрытияОкна>)
ОписаниеОповещения
   Serg_1960
 
3 - 16.03.20 - 10:25
"бьюсь уже час.." - я тоже "уже бьюсь" минуту: зачем "ФормаИсточник = Этаформа.ВладелецФормы;"?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.