Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Несоответствие типов (параметр номер '1')

Несоответствие типов (параметр номер '1')
Я
   yyyuuu
 
16.03.20 - 04:49
Здравствуйте ребята, понять вообще в упор не могу. Дупля не нарезаю просто в чем может быть дело.
Все как по учебнику делаю
Помещаю во временное хранилище список заданий
МассивЗаданий = Новый Массив;
    МассивУИ      = Новый Массив;
    Для Каждого Стр Из ДанныеДляОтправки Цикл
        УникальныйМодификатор = Новый УникальныйИдентификатор;
        МассивУИ.Добавить(УникальныйМодификатор);
        // Формируем массив с параметрами
        ПараметрыЗадания = Новый Массив;
        ПараметрыЗадания.Добавить(Стр.ПутьДляАрхива);
        ПараметрыЗадания.Добавить(Стр.ЖДНакладнаяСсылкаПолучательАдресПаспортаКачества);
        ПараметрыЗадания.Добавить(Неопределено);
        ПараметрыЗадания.Добавить(Стр.ЖдНакладная);
            // Запускаем фоновое выполнение алгоритма
        ФоновыеЗадания.Выполнить(
            // Наш экспортный метод в общем модуле
            "ФоновыеЗаданияОтправка.ОтправкаНаМыло", //из общего модуля
            // Передаем массив с параметрами
            ПараметрыЗадания,
            // Указываем ключ задания
            УникальныйМодификатор,
            // Указываем наименование фонового задания
            "Отправка на почту паспорта качества"
        );
        ПоказатьОповещениеПользователя("Отправка паспорта качества запущена", ,"отчет об отправке будет выведен на экран", БиблиотекаКартинок.Информация32);
        //
        ПодключитьОбработчик();
        ПодключитьОбработчик1();
    //
    КонецЦикла;
    Адреса = ПоместитьВоВременноеХранилище(МассивУИ);



Вызываю



Процедура ОбработатьОжиданиеНаСервере1()
    //
    Если ЭтоАдресВременногоХранилища(Адреса)
        Тогда
            УИ = ПолучитьИзВременногоХранилища(Адреса);
    КонецЕсли;    
    
    //ПараметрыОтбора = Новый Структура("Наименование", УИ);
    //СписокФоновыхЗаданий = ФоновыеЗадания.ПолучитьФоновыеЗадания(ПараметрыОтбора);
    ФоновыеЗадания.ОжидатьЗавершения(УИ);
    ////
    Попытка
            УдалитьФайлы(Путь, "*zip");//ДляАрхива);
    Исключение
            Сообщить(ОписаниеОшибки());
    КонецПопытки;
    //
    ПоказатьОповещениеПользователя("Отправка", ,"Отправка выполненна", БиблиотекаКартинок.Информация32);
КонецПроцедуры

Тут     ФоновыеЗадания.ОжидатьЗавершения(УИ);  Ошибка
{Документ.Налив.Форма.ФормаВ2.Форма(6995)}: Ошибка при вызове метода контекста (ОжидатьЗавершения)
    ФоновыеЗадания.ОжидатьЗавершения(УИ);
по причине:
Несоответствие типов (параметр номер '1')

Хотя передаю массив как и просили с уникальным идентификатором. Уже все перепробовал. МОжет кто подскажет что не так?
   yyyuuu
 
1 - 16.03.20 - 05:10
Для Индекс = 0 по УИ.ВГраница() Цикл
        ПараметрыОтбора = Новый Структура("Ключ", УИ[Индекс]);
        СписокФоновыхЗаданий = ФоновыеЗадания.ПолучитьФоновыеЗадания(ПараметрыОтбора);
        ФоновыеЗадания.ОжидатьЗавершения(СписокФоновыхЗаданий);
    КонецЦикла;

Вроде как разобрался. А Можно бы было это сделать в одно действие без цикла. Я ведь знаю УИ каждого задания он в массиве
   Zmich
 
2 - 16.03.20 - 06:11
(0).
Если ЭтоАдресВременногоХранилища(Адреса)
        Тогда
            УИ = ПолучитьИзВременногоХранилища(Адреса);
    КонецЕсли;

Если условие не выполнится, что будет в УИ?
   yyyuuu
 
3 - 16.03.20 - 06:35
(2) пустой массив
   ДенисЧ
 
4 - 16.03.20 - 06:44
(3) Кто сказал?
   yyyuuu
 
5 - 16.03.20 - 07:44
(4)будет неопредленно, Ошибся Я ребята

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь во втором сообщении вам дадут решение, а в двадцатом дадут правильное решение. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.