Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Пропала кнопка "Выгрузить в файл" ЗУП 3.1 после последнего обновления

Пропала кнопка "Выгрузить в файл" ЗУП 3.1 после последнего обновления
Я
   bfss-732
 
14.03.20 - 09:51
Привет всем!
Беда! Пропала кнопка "Выгрузить в файл" ЗУП 3.1 после последнего обновления в ФормеДокумента и в ФормеСписка  документа  Ведомость в банк. Помогите! Отладчиком нашел различие в работе до обновления и после, разница в
ТабЧасти ДополнительныеРеквизиты.Значение
тип которого: Характеристика.ДополнительныеРеквизитыИСведения
связи параметров выбора: Отбор.Владелец(ДополнительныеРеквизиты.Свойство)
В ОбщемМодуле ОбщегоНазначенияКлиентСервер в Значение должно попадать Ложь, а попадает Истина
Процедура УстановитьСвойствоЭлементаФормы(ЭлементыФормы, ИмяЭлемента, ИмяСвойства, Значение) Экспорт
    
    ЭлементФормы = ЭлементыФормы.Найти(ИмяЭлемента);
    Если ЭлементФормы <> Неопределено И ЭлементФормы[ИмяСвойства] <> Значение Тогда
        ЭлементФормы[ИмяСвойства] = Значение;
    КонецЕсли;
    
КонецПроцедуры

Из-за этого кнопка не появляется. Прошу очень помогите понять, почему попадает Истина?
 
 
   bfss-732
 
1 - 14.03.20 - 09:56
На самом деле даже при открытии формы списка уже нет этой кнопки
   bfss-732
 
2 - 14.03.20 - 09:58
В справочнике Заплатанный проект все настроено правильно, галка "Использовать обмен электронными документами" стоит, все корректно заполнено как и до обнеовления
   bfss-732
 
3 - 14.03.20 - 10:03
(0) Блин, извините напутал, в значение(в этот момент ЭлементыФормы.Найти(ИмяЭлемента) ИмяЭлемента "Выгрузить ВФайлДляОбменаСБанком") попадает Ложь, а должно быть Истина
   bfss-732
 
4 - 14.03.20 - 10:05
Где кнопка "Выгрузить в файл"???????????? https://www.youtube.com/watch?v=jv0cYOllEBE
   hhhh
 
5 - 14.03.20 - 11:38
у пользователя нет прав на обмен с банком
   bfss-732
 
6 - 14.03.20 - 11:42
(5) Под Администратором делаю, полные права и работа с внешними файлами
   ДенисЧ
 
7 - 14.03.20 - 11:44
(6) Полные права ещё не означают, что у админа есть нужные права )))
   bfss-732
 
8 - 14.03.20 - 11:46
(7) Чтение,Просмотр,Изменение,Редактирование,Добавление,Удаление,ИнтерактивноеУдалениеПомеченных,ИнтерактивнаяПометкаУдаления,Проведение,ИнтерактивноеПроведение
Других нет
   bfss-732
 
9 - 14.03.20 - 11:47
(7) Обработки.ОбменСБанками Полные права    Использование,Просмотр    Администратор
   Фрэнки
 
10 - 14.03.20 - 13:33
У меня в базах стоит 3.1.10 и самые свежие обновления.
Кнопка никуда не пропала.

Ничем не могу помочь в понимании. Разве что знаю. что если в зарплатном проекте отключен обмен с банком, то и на форме не будет кнопки для выгрузки в файл.
   Gucci76
 
11 - 14.03.20 - 13:57
Может она в меню ЕЩЕ
Или надо выгружать в банк не из Ведомости, а из Платженых поручений?
Посмотрите журнал "Обмен с банками по зарплатным проектам" . Там есть кнопка выгрузить в файл
   bfss-732
 
12 - 14.03.20 - 14:58
(11) нет там ее
Есть процедура ОбщийМодуль ОбменаСБанкамиПоЗарплатнымПроектам, в которую РазрешенаОтправкаДокумента попадает Ложь! Я не могу понять откуда это берется((( В этом проблема

Процедура ОбновитьКомандыОбменаОбъекта(Форма, Источник, РазрешенаОтправкаДокумента = Истина) Экспорт
    
    Для Каждого КомандаОбмена Из Форма.КомандыОбмена Цикл
        ПоказыватьКоманду = Истина;
        Если Не РазрешенаОтправкаДокумента Или КомандаОбмена.Значение.Найти(Источник) = Неопределено Тогда
            ПоказыватьКоманду = Ложь;
        КонецЕсли;
        ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(Форма.Элементы, КомандаОбмена.Ключ, "Видимость", ПоказыватьКоманду);
    КонецЦикла;
   bfss-732
 
13 - 14.03.20 - 15:02
(11) "Посмотрите журнал "Обмен с банками по зарплатным проектам" . Там есть кнопка выгрузить в файл" Там есть эта кнопка
   Gucci76
 
14 - 14.03.20 - 16:42
(13) Поздравляю с находкой! )))))
Может кто знает, почему туда кнопка сбежала?
Тоже такая ситуация была!
   Фрэнки
 
15 - 14.03.20 - 17:09
т.е. кто-то за вас, хотя у вас самих способностей и возможностей хватает, должен отследить по стеку или как-либо еще отладчиком установку параметра РазрешенаОтправкаДокумента ?

При том, что на релизах 3.1.10 ничего никуда не сбежало и это нужно нарочно устанавливать именно тот релиз, который есть теперь у вас, но никто не знает какой.
   Gucci76
 
16 - 14.03.20 - 22:55
(15) Я не просил лезть в конфигуратор. А интересовался, что может кто уже владеет информацией и не против ей поделиться!
   bfss-732
 
17 - 16.03.20 - 09:08
Вопрос решился! Не знаю почему но накатилось кривое обновление ЗУПа. От безысходность обновил копию базы по новому и кнопка появилась))) Жесть!!! Теперь решаю вопрос как корректно откатить обновление, т.к. накат .cf на одно и ту же конфу ничего не дало.
   Фрэнки
 
18 - 16.03.20 - 09:24
А чем глобальным копия, на которую накатывал тест, отличается от того, что происходило в продуктиве? Может просто не выполнились регламентные процедуры, а при тесте файловой версии все выполнилось само в монопольном режиме сходу?
   arsik
 
19 - 16.03.20 - 09:51
(18) Скорее всего кеш виноват.
   bfss-732
 
20 - 16.03.20 - 13:24
(18) скорее всего да
   bfss-732
 
21 - 16.03.20 - 13:24
(19) скорее всего нет
   bfss-732
 
22 - 16.03.20 - 13:26
(17) пришлось бэкап до обновления доставать и обнавлять по новому, кнопка на месте. С .cf фокусы не прошли никакие.
   Serg_1960
 
23 - 16.03.20 - 14:11
Если не помогло выгрузить CF из базы (где есть кнопка) и загрузить в базу (где кнопки нет) - кэш. Однозначно.
   Mihasya
 
24 - 16.03.20 - 14:59
Еще - Изменить форму, там поставить галочку на кнопке )))
   bfss-732
 
25 - 16.03.20 - 15:02
(23) проверю, отпишусь обязательно, самому интересно
   bfss-732
 
26 - 16.03.20 - 15:02
(24) там нет ее, это самое первое что проверял


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.