Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ИнтернетПочтовоеСообщение: как указать нужный шрифт?

ИнтернетПочтовоеСообщение: как указать нужный шрифт?
Я
   Айвонттубифри
 
13.03.20 - 16:15
Подскажите, как в тексте письма указать нужный шрифт (Calibri, размер 11)?


Процедура ОтправитьПисьмо(мОтобранныеСтроки);
    
    Письмо = Новый ИнтернетПочтовоеСообщение;
    
    ТекстПисьма = "  Здравствуйте, " + ДанныеСтруктуры.Руководитель + "!" + "
    |<br />
    |<br />
    |<br />  Скоро начинается отпуск у сотрудника(ов) департамента: " + "
    |";
    
    ТекстПисьма = ТекстПисьма + "<table border='1px'><th>ФИО</th><th>Дата начала</th><th>Дата окончания</th>";
    
    Для каждого Строка Из мОтобранныеСтроки Цикл
        ТекстПисьма = ТекстПисьма + "<tr>";
        ТекстПисьма = ТекстПисьма + "<td>" + Строка.Сотрудник + "</td>";
        ТекстПисьма = ТекстПисьма + "<td>" + Формат(Строка.ДатаНачала, "ДФ=dd.MM.yyyy") + "г.</td>";
        ТекстПисьма = ТекстПисьма + "<td>" + Формат(Строка.ДатаОкончания, "ДФ=dd.MM.yyyy") + "г.</td>";
        ТекстПисьма = ТекстПисьма + "</tr>";
    КонецЦикла;
    ТекстПисьма = ТекстПисьма + "</table>";
    
    ТекстПисьма = ТекстПисьма + "
    |<br />
    |<br />
    |<br />  Просим проконтролировать передачу заявления на отпуск в ДРП (не позднее, чем за 2 недели до начала отпуска). " + "
    |<br />  Если даты отпуска поменяются, оповестите нас, пожалуйста. " + "
    |";
    
    Текст = Письмо.Тексты.Добавить(ТекстПисьма);
    Текст.ТипТекста = ТипТекстаПочтовогоСообщения.HTML;
    
КонецПроцедуры
 
 
   ДенисЧ
 
1 - 13.03.20 - 16:17
google://как+задать+шрифт+в+html+документе
   Asmody
 
2 - 13.03.20 - 16:54
(0) А почему вы уверены, что у получателя стоит шрифт Calibri?
   runoff_runoff
 
3 - 13.03.20 - 16:57
   Айвонттубифри
 
4 - 13.03.20 - 18:14
(1) Примеров с 1С - не нашла...

HELP!!!
   ДенисЧ
 
5 - 13.03.20 - 18:34
(4) А если абстрагироваться от 1с и нарисовать нормальный well-formed html?
   Айвонттубифри
 
6 - 13.03.20 - 18:52
Выдает ошибку, если пишу вот так:

ТекстПисьма = ТекстПисьма + "<font face"<"Calibri">"</font>";  //ошибка на этой строке

Текст = Письмо.Тексты.Добавить(ТекстПисьма);
Текст.ТипТекста = ТипТекстаПочтовогоСообщения.HTML;
   ДенисЧ
 
7 - 13.03.20 - 18:56
"<font face"<"Calibri">"</font>";

Это дословно?? Хорошо, что я не твоя 1с... Иначе бы из монитора вылез и...
   ДенисЧ
 
8 - 13.03.20 - 19:00
Вот, прочти. И не позорься.
   ДенисЧ
 
9 - 13.03.20 - 19:00
   Айвонттубифри
 
10 - 13.03.20 - 19:04
Вот так ошибку не выдает, но шрифт не меняет:

ТекстПисьма = ТекстПисьма + "<p style='font-size:11px ; font-weight:100; font-family: Calibri;'> </p>";  
Текст = Письмо.Тексты.Добавить(ТекстПисьма);
Текст.ТипТекста = ТипТекстаПочтовогоСообщения.HTML;
   ДенисЧ
 
11 - 13.03.20 - 19:27
(10) А где видишь, что не меняет? В каком клиенте письмо смотришь?

Кстати, большинство цеб-почт на стили плюют...
   Айвонттубифри
 
12 - 13.03.20 - 19:30
(11) Я письмо отправляю сама себе и вижу, что оно приходит не со шрифтом Calibri 11.
   Lama12
 
13 - 13.03.20 - 19:38
(12) Может сначала сделать просто файл HTML в котором будет нужный шрифт. Потом использовать этот файл как тело письма и отправить его себе на почту. Посмотреть что получится. Вдруг окажется что клиент игнорирует шрифт.
   ДенисЧ
 
14 - 13.03.20 - 19:41
(12) "В каком клиенте письмо смотришь?"

Вроде по-русски написал...

Я же не спросил, _кто_ читает письмо...
   Сияющий в темноте
 
15 - 13.03.20 - 19:44
(10) открыть абзац,задав для него шрифт и потом звкрыть через </p> а после указать текст письма.
по-мойму,кто-то даже на дятла клювом не вышел.
   Айвонттубифри
 
16 - 13.03.20 - 19:46
(14) Тонкий клиент, ЗУП3.

Я вас всех не понимаю... Где ошибка?
   ДенисЧ
 
17 - 13.03.20 - 19:50
(16) читай (15) , потом внимательно подумай над (5) и (13) ...
   Garykom
 
18 - 13.03.20 - 20:04
Если у получателя письма нет колибри то он заменится на любой подходящий шрифт.

Картинки оправляй...
   Asmody
 
19 - 13.03.20 - 20:33
(16) ошибка в желании использовать в письме конкретный шрифт.
Если ваше письмо откроют на айфоне, маке, андроиде или в линуксе, никакого Calibri там не будет.
   Asmody
 
20 - 13.03.20 - 20:36
Вот тут читать https://m.habr.com/ru/post/252279/
   Asmody
 
21 - 13.03.20 - 20:42
Цитата:
В почтовых рассылках допускается использование только стандартных шрифтовых наборов, которые присутствуют на всех устройствах. Представляю вашему вниманию список безопасных шрифтов, которые есть на всех устройствах:
font-family: Arial, Helvetica, sans-serif;
font-family: 'Arial Black', Gadget, sans-serif;
font-family: Georgia, serif;
font-family: 'MS Sans Serif', Geneva, sans-serif;
font-family: 'MS Serif', 'New York', sans-serif;
font-family: Tahoma, Geneva, sans-serif;
font-family: 'Times New Roman', Times, serif;
font-family: 'Trebuchet MS', Helvetica, sans-serif;
font-family: Verdana, Geneva, sans-serif;
   Сияющий в темноте
 
22 - 15.03.20 - 15:47
там можно указать набор штрифтов,чтобы выбирало первый найденный.
   Айвонттубифри
 
23 - 16.03.20 - 11:39
Столько пустой воды в ответах, и оскорбить в (15) успели... Мда, мужчины нынче не те...

Если кому понадобится, вот решение:


ТекстПисьма = "<div style='font-family:Calibri; font-size:11pt'>  Здравствуйте, " + ДанныеСтруктуры.Руководитель + "!" + "
    |<br />
    |<br />
    |<br />  Скоро начинается отпуск у сотрудника(ов) департамента: " + " 
    |";
    
    ТекстПисьма = ТекстПисьма + "<table border='1px' style='font-family:Calibri; font-size:11pt'><th>ФИО</th><th>Дата начала</th><th>Дата окончания</th>";
    
    Для каждого Строка Из мОтобранныеСтроки Цикл
        ТекстПисьма = ТекстПисьма + "<tr>";
        ТекстПисьма = ТекстПисьма + "<td>" + Строка.Сотрудник + "</td>";
        ТекстПисьма = ТекстПисьма + "<td>" + Формат(Строка.ДатаНачала, "ДФ=dd.MM.yyyy") + "г.</td>";
        ТекстПисьма = ТекстПисьма + "<td>" + Формат(Строка.ДатаОкончания, "ДФ=dd.MM.yyyy") + "г.</td>";
        ТекстПисьма = ТекстПисьма + "</tr>";
    КонецЦикла;
    ТекстПисьма = ТекстПисьма + "</table>";
    
    ТекстПисьма = ТекстПисьма + "
    |<br />
    |<br />
    |<br />  Просим проконтролировать передачу заявления на отпуск в ДРП (не позднее, чем за 2 недели до начала отпуска). " + " 
    |<br />  Если даты отпуска поменяются, оповестите нас, пожалуйста. " + " 
    |</div>";
   ДенисЧ
 
24 - 16.03.20 - 11:44
(23) А вот у меня на компе нет этого каллибри... И что я увижу в итоге?
   Айвонттубифри
 
25 - 16.03.20 - 12:18
(24) Это корпоративная рассылка внутри компании, поэтому данный шрифт 100% стоит у всех.
   arsik
 
26 - 16.03.20 - 12:21
(25) :)
   ДенисЧ
 
27 - 16.03.20 - 12:23
(25) А если я захочу эту рассылку с своего айфона прочитать? (это не выдумка, это случай из жизни) ?


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.