Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Создание пользователя в режиме 1С:Предприятие

Создание пользователя в режиме 1С:Предприятие
Я
   farengeit2009
 
13.03.20 - 12:47
Подскажите, пожалуйста, как создать пользователя в режиме Предприятие. Версия 1С Предприятие 8.3.
   Tatitutu
 
1 - 13.03.20 - 12:48
Программно или ручками
конфигурация какая ?
ты кто ?
   farengeit2009
 
2 - 13.03.20 - 12:53
Ручками. Учебная конфигурация
   Winnie Buh
 
3 - 13.03.20 - 13:52
(2) смотря какая именно учебная конфигурация, есть учебные конфы БП, УНФ, УТ
если это самописка с нуля, то только через конфигуратор
   ejikbeznojek
 
4 - 13.03.20 - 13:53
Ну или добавить в конфигураторе возможность создавать пользователей из предприятия.
Скопипасть откуда-нибудь справочник пользователи и пару страниц кода.
   Кодер
 
5 - 13.03.20 - 14:33
См. ограничения учебной версии.
   farengeit2009
 
6 - 14.03.20 - 09:14
Хочу чтобы при создании в справочнике Пользователи нового элемента с конкретной ролью в реквитизите Роль и другими данными создавался пользователь в ИБ. Вот код:

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)

НовыйПользователь = ПользователиИнформационнойБазы.СоздатьПользователя();
НовыйПользователь.Имя = Объект.Имя;
НовыйПользователь.ПолноеИмя = Объект.ПолноеИмя;
НовыйПользователь.АутентификацияСтандартная = Истина;
НовыйПользователь.Пароль = Объект.Пароль;
НовыйПользователь.Роли.Добавить(Метаданные.Роли.Объект.Роль);
НовыйПользователь.ПоказыватьВСпискеВыбора = Истина ;
НовыйПользователь.Язык = Метаданные.Языки.Русский;
НовыйПользователь.Записать();

КонецПроцедуры
Пишет поле Объект не найдено. Как правильно написать?
   Aleksey
 
7 - 14.03.20 - 09:23
(6) что такое Объект и ТекущийОбъект?
   farengeit2009
 
8 - 14.03.20 - 09:24
Забыл сказать, что в этой строке
НовыйПользователь.Роли.Добавить(Метаданные.Роли.Объект.Роль);
   farengeit2009
 
9 - 14.03.20 - 09:26
Объект - основной реквизит. ТекущийОбъект - форма, которая будет сохраняться
   Garykom
 
10 - 14.03.20 - 09:29
(6) Телепаты в выходные спят еще. Этот код у тебя где расположен?
   farengeit2009
 
11 - 14.03.20 - 09:32
(10) Код в форме элемента расположен
   Волшебник
 
Модератор
12 - 14.03.20 - 09:35
(8) надо так:
Метаданные.Роли.ИмяРоли
   Волшебник
 
Модератор
13 - 14.03.20 - 09:36
или так:
Метаданные.Роли[Объект.Роль];
кстати, пароли пользователей в учебной версии не поддерживаются
   farengeit2009
 
14 - 14.03.20 - 09:37
(13) Версия уже неучебная))
   Волшебник
 
Модератор
15 - 14.03.20 - 09:38
(3) А ещё бывает учебная ERP :)
   farengeit2009
 
16 - 14.03.20 - 09:40
Волшебник, спасибо. Теперь работает.
   farengeit2009
 
17 - 15.03.20 - 10:21
Доброе утро всем. Подскажите, пожалуйста, 
решение обратной задачи. Добавляется пользователь в ИБ в режиме конфигуратора. Нужно чтобы он добавился сразу в справочник
   Фрэнки
 
18 - 15.03.20 - 10:24
(17) "При начале работы сеанса" - можно в обработчике этого события проверить наличие Пользователя в справочнике Пользователи и добавить при необходимости.
Есть методы ПользовательИБ
   Фрэнки
 
19 - 15.03.20 - 10:32
Там есть специальный Модуль сеанса. Открой его от корня конфигурации. Находясь в модуле смотри на список преодпределенных обработчиков событий в этом модуле.
В списке событий увидишь ПриНачалеРаботыСистемы (выше я неверно описал что при начале работы сеанса)

https://its.1c.ru/db/bsp301doc/content/479/hdoc

А дальше прочти еще эту доку

https://its.1c.ru/db/v8std#content:413:hdoc
   farengeit2009
 
20 - 15.03.20 - 10:36
понял, спасибо. попробую разобраться
   farengeit2009
 
21 - 15.03.20 - 10:42
к сожалению нет доступа к ИТС...
   Фрэнки
 
22 - 15.03.20 - 10:43
(21) там же бесплатная регистрация на 7 дней есть
   farengeit2009
 
23 - 15.03.20 - 10:44
уже использована
   Фрэнки
 
24 - 15.03.20 - 10:44
лишние ящики и получать по 7 дней на каждый новый ящик
   Фрэнки
 
25 - 15.03.20 - 10:45
ну вот еще ссылка

https://helpf.pro/faq/view/948.html
   farengeit2009
 
26 - 15.03.20 - 10:46
мысль)
   Фрэнки
 
27 - 15.03.20 - 10:51
(26) а что в версии поставки, откуда взята была платформа, там готовой учебной конфигурации разве нет у тебя?
Может есть смысл скачать свежую версию для обучения программированию в том виде, как ее для установки под винду раздают?

https://uc1.1c.ru/uchebnaya-versiya-1s/
   farengeit2009
 
28 - 15.03.20 - 10:53
Только немного не пойму - модуль сеанса выполняется при старте системы для инициализации параметров сеанса и обработки действий, связанных с сеансом работы. А в поставленной задаче Пользователь добавляется в список ИБ интерактивно и потом программно заносится в справочник.
   Фрэнки
 
29 - 15.03.20 - 11:04
(28) не совсем "интерактивно" - у тебя в списке пользователей ИБ он уже есть. И в сеанс ты входишь как Пользователь. И непосредственно в процессе входа оказывается что?

Вход есть. Под Пользователем из ПользователиИнформационнойБазы . Параметр сеанса должен быть. А в справочнике Пользователи элемента нет.
   farengeit2009
 
30 - 15.03.20 - 11:10
задача такая - заходишь в режим конфигуратор с правами доступа администратор или полными правами, заходишь на вкладку Администрирование и добавляем нового пользователя, а он автоматом заносится в любой созданный справочник, например, Пользователи.
 
 Рекламное место пустует
   Фрэнки
 
31 - 15.03.20 - 11:15
(30) нет. В режиме конфигуратора ты сможешь создать только в ПользователиИнформационнойБазы
А затем, уже при первом входе под этим выбранным из списка, нужно выполнить некий программный код, который создаст элемент в справочнике Пользователи.

Вот если под этим новым выбранным входить ни разу не будешь, а посмотришь на справочник Пользователи в другом сеансе, то нового элемента там не найдешь.
   farengeit2009
 
32 - 15.03.20 - 11:53
Спасибо, Френки
   farengeit2009
 
33 - 16.03.20 - 10:38
Подскажите, пожалуйста, как получить роль пользователя ИБ. Пользователь.Роль = ПользовательИБ.Роли выдает "Роли пользователя"
   farengeit2009
 
34 - 16.03.20 - 10:46
&НаСервере
Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    СписокПользователей = ПользователиИнформационнойБазы.ПолучитьПользователей();
    Для Каждого Пользователь  Из СписокПольЗователей Цикл
        ТекПользователь =  Справочники.Пользователи.НайтиПоНаименованию(Пользователь.Имя);
            Если ТекПользователь.Пустая() Тогда
            Создать =  Справочники.Пользователи.СоздатьЭлемент();
            Создать.Имя = Пользователь.Имя;
            Создать.ПолноеИмя = Пользователь.ПолноеИмя;
            //Создать.Пароль = Пользователь.Пароль;

            Создать.Роль = Пользователь.Роли;
            Создать.ПоказыватьВСписке = Пользователь.ПоказыватьВСпискеВыбора;
            Создать.Записать();
       КонецЕсли;
    КонецЦикла;
КонецПроцедуры
   ejikbeznojek
 
35 - 16.03.20 - 13:49
Может быть
ТвояРоль=создать.роли.добавить();
ТвояРоль.Использование = истина;
ТвояРоль.Роль=НайдиНужнуюТебеРольВ_Метаданные.Роли)
   farengeit2009
 
36 - 16.03.20 - 14:01
Роль уже создана в конфигурации ручками, поэтому не подойдёт
   ejikbeznojek
 
37 - 16.03.20 - 14:06
(36) Ну ладно...хотя в этом коде роль не создаётся а добавляется в список ролей к твоему пользователю "создать"


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.