Вход | Регистрация
 

вместо наименования хочу чтобы отображалась строка вида Наименование + Реквизит1 + Реквизи

вместо наименования хочу чтобы отображалась строка вида Наименование + Реквизит1 + Реквизи
Я
   golem14
 
13.03.20 - 09:24
Есть Справочник1 у него есть Наименование, Реквизит1, Реквизит2.
Нужно в ТЧ Документа вывести этот справочник в ОДНУ колонку,
но вместо наименования хочу чтобы отображалась строка вида Наименование + Реквизит1 + Реквизит2.
Как это сделать?
 
 
   FIXXXL
 
1 - 13.03.20 - 09:25
(0) по разному можно...
   Звездец
 
2 - 13.03.20 - 09:25
код писать придется. Это сложно, забей
   golem14
 
3 - 13.03.20 - 09:27
так не получилается
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    Для каждого строка из Элементы.ТабличнаяЧасть1 Цикл
    КонецЦикла;
    
КонецПроцедуры
   Максимка_ Космонавтом
 
4 - 13.03.20 - 09:28
(0) Смотри обработчики менеджера
   golem14
 
5 - 13.03.20 - 09:31
(4) ОбработкаПолученияПредставления?
   Cyberhawk
 
6 - 13.03.20 - 09:35
(5) И полей представления тоже
   dka80
 
7 - 13.03.20 - 09:42
(5) только это будет везде так, а не только в твоем документе
   golem14
 
8 - 13.03.20 - 09:43
Спасибо, получилось.
Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Представление = Данные.Ссылка.Наименование +" "+ Данные.Ссылка.Реквизит1 +" "+ Данные.Ссылка.Реквизит2;
КонецПроцедуры
   GROOVY
 
9 - 13.03.20 - 09:52
(8) Получилось то да... Но ты убиваешь систему.

Гугли ОбработкаПолученияПолейПредставления.
   Затейник
 
10 - 13.03.20 - 10:26
(0) Дай угадаю, хотелка какого-то пользователя ?
   golem14
 
11 - 13.03.20 - 10:37
(10) ессно
   golem14
 
12 - 13.03.20 - 11:13
Более правильный вариант:


Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    Представление = Данные.Наименование + " " + Данные.Реквизит1 + " " + Данные.Данные.Реквизит2;
    
КонецПроцедуры

Процедура ОбработкаПолученияПолейПредставления(Поля, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    Поля.Добавить("Наименование");
    Поля.Добавить("Реквизит1");
    Поля.Добавить("Реквизит2");
    
КонецПроцедуры
   Начинающий_13
 
13 - 13.03.20 - 11:28
//// № Формируем наименование банковского счета организации

    СтруктураРеквизитов = Новый Структура;
    СтруктураРеквизитов.Вставить("НомерСчета" , Объект.НомерСчета );
    СтруктураРеквизитов.Вставить("Валюта"     , Объект.Валюта);
    СтруктураРеквизитов.Вставить("ВидСчета"   , Объект.ВидСчета);
    СтруктураРеквизитов.Вставить("СчетУчета"  , Объект.СчетУчета);
    Если НЕ ЗначениеЗаполнено(Объект.Наименование)Тогда
        Объект.Наименование = "Основной банковский счет";
    Иначе
        
        Слова = Новый Массив;
        Если ЗначениеЗаполнено(СтруктураРеквизитов.НомерСчета) Тогда
            Слова.Добавить(СтрШаблон(НСтр("ru = '№ %1'"), СокрЛП(СтруктураРеквизитов.НомерСчета)));
        КонецЕсли;
        Если ЗначениеЗаполнено(СтруктураРеквизитов.Валюта) Тогда
            Слова.Добавить(СтрШаблон(НСтр("ru = 'в %1'"), СтруктураРеквизитов.Валюта));
        КонецЕсли;
        Если ЗначениеЗаполнено(СтруктураРеквизитов.СчетУчета) Тогда
            Слова.Добавить(СтрШаблон(НСтр("ru = 'учет %1'"), СокрЛП(СтруктураРеквизитов.СчетУчета)));
        КонецЕсли;
        Если ЗначениеЗаполнено(СтруктураРеквизитов.ВидСчета) Тогда
            Слова.Добавить(СтрШаблон(НСтр("ru = '%1'"), СокрЛП(СтруктураРеквизитов.ВидСчета)));
        КонецЕсли;
                
        Объект.Наименование = СтрСоединить(Слова, " ");
    КонецЕсли;

Список тем форума
Рекламное место пустует  Рекламное место пустует
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.