Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Загрузить на вебклиент?

Загрузить на вебклиент?
Я
   МаленькийВопросик
 
11.03.20 - 18:05
пишу процедуры


вроде передает, но не получает

&НаКлиенте
Процедура ИмяФайлаКодовНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    
    ОписаниеОповещения = Новый ОписаниеОповещения("ОбработатьВыборФайла", ЭтаФорма);
    ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
        
    НачатьПомещениеФайлов(ОписаниеОповещения, , ДиалогОткрытияФайла, Истина, УникальныйИдентификатор);
    
    
КонецПроцедуры


&НаКлиенте
Процедура ОбработатьВыборФайла(ПомещенныеФайлы, ДополнительныеПараметры) Экспорт


    Для каждого ПереданныйФайл Из ПомещенныеФайлы Цикл
        
        Сообщить(ТипЗнч(ПереданныйФайл.Хранение));
        
        ЗагрузитьНаСервере(ПереданныйФайл.Хранение);
        
            
    КонецЦикла;
  
КонецПроцедуры



Процедура ЗагрузитьНаСервере(Адрес)
    ЗагружаемыйФайл = Новый ТекстовыйДокумент;
    ЗагружаемыйФайл.Прочитать(Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(Адрес)));

....


подскажите, что подправить в коде? спасибо.
 
 
   DrWatson
 
1 - 11.03.20 - 19:03
(0) Читаю СП для ЗагружаемыйФайл.Прочитать - там написано, что первый параметр строка "Имя файлы". А у тебя там нагромождение какое-то.
Посмотри что у тебя в ПолучитьИзВременногоХранилища(Адрес). Наверняка, этого будет достаточно.
   Сияющий в темноте
 
2 - 11.03.20 - 19:06
ну и проверить расширение для работы с файлами,а то-нет расширения,нет и файлов.
   МаленькийВопросик
 
3 - 11.03.20 - 19:11
пишет, что файл не обнаружен

весь смысл - работать без расширения 8.3.15.1830

Список тем форума
Рекламное место пустует  Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.