Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Вывод в макет табличную часть из другого документа

Вывод в макет табличную часть из другого документа
Я
   Multicvet
 
11.03.20 - 14:58
Привет!
Голову поломал, направьте, пожалуйста. Создаю макет, в макет хочу вывести табличную часть из связанного документа. При формировании - ругань: Метод объекта не обнаружен (Выбрать). Что не так?

Процедура Печать(ТабДок, Ссылка) Экспорт
    //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
    Макет = Документы.ЗаявкаНаТранспорт.ПолучитьМакет("Печать");
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    ЗаявкаНаТранспорт.Водитель,
    |    ЗаявкаНаТранспорт.Грузчик1,
    |    ЗаявкаНаТранспорт.Грузчик2,
    |    ЗаявкаНаТранспорт.Дата,
    |    ЗаявкаНаТранспорт.ДатаДоставки,
    |    ЗаявкаНаТранспорт.Километраж,
    |    ЗаявкаНаТранспорт.Клиент,
    |    ЗаявкаНаТранспорт.Комментарий,
    |    ЗаявкаНаТранспорт.КонтактноеЛицо,
    |    ЗаявкаНаТранспорт.Номер,
    |    ЗаявкаНаТранспорт.Основание,
    |    ЗаявкаНаТранспорт.Телефон,
    |    ЗаявкаНаТранспорт.ТранспортноеСредство,
    |    ЗаявкаНаТранспорт.Основание.Товары.(
    |        Номенклатура КАК Номенклатура,
    |        Количество КАК Количество,
    |        Цена КАК Цена,
    |        Сумма КАК Сумма
    |    ) КАК ОснованиеТовары
    |ИЗ
    |    Документ.ЗаявкаНаТранспорт КАК ЗаявкаНаТранспорт
    |ГДЕ
    |    ЗаявкаНаТранспорт.Ссылка В(&Ссылка)";
    Запрос.Параметры.Вставить("Ссылка", Ссылка);
    Выборка = Запрос.Выполнить().Выбрать();

    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    Шапка = Макет.ПолучитьОбласть("Шапка");
    ОбластьТоварыШапка = Макет.ПолучитьОбласть("ТоварыШапка");
    ОбластьТовары = Макет.ПолучитьОбласть("Товары");
    ТабДок.Очистить();

    ВставлятьРазделительСтраниц = Ложь;
    Пока Выборка.Следующий() Цикл
        Если ВставлятьРазделительСтраниц Тогда
            ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;

        ТабДок.Вывести(ОбластьЗаголовок);

        Шапка.Параметры.Заполнить(Выборка);
        ТабДок.Вывести(Шапка, Выборка.Уровень());
        ТабДок.Вывести(ОбластьТоварыШапка);
        
        ВыборкаТовары = Выборка.Основание.Выбрать();
        Пока ВыборкаТовары.Следующий() Цикл
            ОбластьТовары.Параметры.Заполнить(ВыборкаТовары);
            ТабДок.Вывести(ОбластьТовары, ВыборкаТовары.Уровень());
        КонецЦикла;

        ВставлятьРазделительСтраниц = Истина;
    КонецЦикла;
    //}}
КонецПроцедуры
   ДенисЧ
 
1 - 11.03.20 - 14:59
|    ) КАК ОснованиеТовары 

...


ВыборкаТовары = Выборка.Основание.Выбрать(); 

Дальше сам...
   Multicvet
 
2 - 11.03.20 - 15:46
(1) Спасибо!
Ну точно! Невнимательный я...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.