Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Конвертация данных 2.1 ошибка в ПКО номенклатура

Конвертация данных 2.1 ошибка в ПКО номенклатура
Я
   lite777
 
11.03.20 - 09:59
Добрый день настраиваю правила ут10.3-Розн ,ПКО Номенклатура-Номенклатура,стоит галка в ПКС -ЭтоГруппа, выдает ошибку при выгрузке- Ошибка получения значения свойства объекта (по имени свойства источника),почему объект -структура где это искать ?
    
        ПКО                    =  Номенклатура  (Справочник: Номенклатура)
    ПКС                    =  13  (ЭтоГруппа --> ЭтоГруппа)
    Объект                 =  Структура  (Структура)
    СвойствоПриемника      =  ЭтоГруппа  (Булево)
    ОписаниеОшибки         =  Поле объекта не обнаружено (ЭтоГруппа)
    ПозицияМодуля          =  Обработка.УниверсальныйОбменДаннымиXML(8196)
    КодСообщения           =  13
   hhhh
 
1 - 11.03.20 - 10:22
(0) забыли в эту структуру
Объект                 =  Структура  (Структура) 

включить свойство ЭтоГруппа
   lite777
 
2 - 11.03.20 - 10:27
(1) Счас стоит Галка (поиск) в Конвертации свойст ЭТОГруппа
   lite777
 
3 - 11.03.20 - 10:33
Что Забыли ?
   azt-yur
 
4 - 11.03.20 - 10:51
Где то в правилах используют ВыгрузитьПоПравилу, где источником указывают структуру, а в ней нет ЭтоГруппа.
Можешь костыль поставить в ПКС ЭтоГруппа в перед выгрузкой что то типа:
Если ТипЗнч(Источник) = Тип("Структура") И Не Источник.Свойство("ЭтоГруппа") Тогда
 Значение = Ложь;
КонецЕсли;
   lite777
 
5 - 11.03.20 - 11:01
(4) Попробую
   lite777
 
6 - 11.03.20 - 11:02
(4) В правилах выгрузки ? используют ВыгрузитьПоПравилу,
   lite777
 
7 - 11.03.20 - 11:22
В Конвертации  на основной вкладке , Перед конвертацией объекта  нашел такое-

Если ТипЗнч(ВходящиеДанные) <> Тип("Структура") Тогда
    ВходящиеДанные = Новый Структура;
КонецЕсли;

Если ТипЗнч(ИсходящиеДанные) <> Тип("Структура") Тогда
    ИсходящиеДанные = Новый Структура;
КонецЕсли;
   azt-yur
 
8 - 11.03.20 - 11:25
(7) это другое.
(6) Может где угодно. Открой правила в текстовом редакторе и поищи поиском фразу ВыгрузитьПоПравилу. Может так найдешь

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.