Вход | Регистрация
 

Как реализовать отбор по контрагенту договора?

↓ [Fish, 11.03.20 - 11:50]
Как реализовать отбор по контрагенту   договора?
Я
   KoderZ
 
10.03.20 - 17:01
Всем привет!
Подскажите есть два поля в форме обработки   Владелец - Контрагент и Договор

как можно программно отобрать договора выбранного контрагента?
 
 
   dka80
 
1 - 10.03.20 - 17:03
Ты хочешь, чтобы в форме подбора договоров показались только договора выбранного контрагента? Используй Свойство поля Договор "Связь параметров выбора"
   KoderZ
 
2 - 10.03.20 - 17:05
(1) не хочу я связи параметров использовать . мне надо  если выбран  контрагент отбирать .если не выбран . то все договора можно их искать по названию в поле выбора .
   dka80
 
3 - 10.03.20 - 17:10
Ну при открытии формы подбора устанавливай или тогда отбор на владельца, либо передавай конкретный допустимый список договоров.
А сам список выбирай запросом
   KoderZ
 
4 - 10.03.20 - 17:13
(3) пример можно? рабочий
   Cyberhawk
 
5 - 10.03.20 - 17:19
Платформенные связи параметров выбора не устраивают тем, что при выборе договора тебя заставляют сначала выбрать контрагента?
Так это не платформенные, это прикладная форма выбора договора так себя ведет.
   dka80
 
6 - 10.03.20 - 17:21
ЗначениеОтбора = Новый Структура("ЗарплатныйПроект", ЗарплатныйПроект(ЦелеваяЗаявка));
    ПараметрыВыбора = Новый Структура("Отбор", ЗначениеОтбора);
    
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("РежимВыбора", Истина);
    ПараметрыФормы.Вставить("МножественныйВыбор", Истина);
    ПараметрыФормы.Вставить("Отбор", ЗначениеОтбора);
    Форма = ПолучитьФорму("Документ.ЗаявкаНаОткрытиеЛицевыхСчетовСотрудников.ФормаСписка", ПараметрыФормы, ЭтаФорма);
    Форма.Открыть();
   KoderZ
 
7 - 10.03.20 - 17:25
(6) щас проверю
   KoderZ
 
8 - 10.03.20 - 17:27
(6) ЗначениеОтбора = Новый Структура("Владелец", Объект.Владелец);
    ПараметрыВыбора = Новый Структура("Отбор", ЗначениеОтбора);
    
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("РежимВыбора", Истина);
    ПараметрыФормы.Вставить("МножественныйВыбор", Истина);
    ПараметрыФормы.Вставить("Отбор", ЗначениеОтбора);
    Форма = ПолучитьФорму("Справочник.ДоговорыКонтрагентов.ФормаСписка", ПараметрыФормы, ЭтаФорма);
    Форма.Открыть();
    
так?
   vicof
 
9 - 10.03.20 - 17:31
Нет
   Chameleon1980
 
10 - 10.03.20 - 17:32
(8) ну а тебе не видно получилось или нет?
   vicof
 
11 - 10.03.20 - 17:32
Владельца у контрагента нет
   KoderZ
 
12 - 10.03.20 - 17:33
(11) он в форме назван как Владелец
   vicof
 
13 - 10.03.20 - 17:33
(12) Тогда ладно)
   KoderZ
 
14 - 10.03.20 - 17:37
Несоответствие типов
{Обработка.РабочееМестоЛизинг.Форма.ФормаЭлемента.Форма(3329)}:    ПараметрыВыбора = Новый Структура("Отбор", ЗначениеОтбора);

по причине:
Несоответствие типов
   vicof
 
15 - 10.03.20 - 17:37
Назови ПараметрыВыбора по-другому
   KoderZ
 
16 - 10.03.20 - 17:38
(15) это как?
   dka80
 
17 - 10.03.20 - 17:39
ПараметрыВыбора = Новый Структура("Отбор", ЗначениеОтбора);

Вот эта строка зачем тебе вообще?
   vicof
 
18 - 10.03.20 - 17:40
ПараметрыВыбора2, например
   acht
 
19 - 10.03.20 - 18:57
(14) Снова с лизингом маятесь, Андрей Николаевич?
   KoderZ
 
20 - 11.03.20 - 09:34
(19) маетесь это вы. а мы трудимся
   Михаил Михайлович
 
21 - 11.03.20 - 09:50
опять ливингстар?
   KoderZ
 
22 - 11.03.20 - 10:16
(21) это .что по русски ?
   KoderZ
 
23 - 11.03.20 - 10:16
не работает отбор . что я делаю не так?

&НаКлиенте
Процедура ВладелецНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    
    
        СтандартнаяОбработка = Ложь;
    
    ПараметрыФормы = Новый Структура;
    
    Отборы = Новый Структура;
    Отборы.Вставить("Владелец", Объект.Владелец);
 
    
    ПараметрыФормы.Вставить("Отбор", Отборы);
    
    ОткрытьФорму("Справочник.ДоговорыКонтрагентов.ФормаВыбора", ПараметрыФормы, Элементы.Владелец);
 
 
 
 
КонецПроцедуры
   hhhh
 
24 - 11.03.20 - 10:27
(23) вот тут хрень какая-то

Элементы.Владелец

что за Элементы.Владелец ??
   KoderZ
 
25 - 11.03.20 - 10:34
(24) поле выбора контрагента . имя Владелец .путь к данным Объект.Владелец
Объект- Справочник ДоговораКонтрагентов
   hhhh
 
26 - 11.03.20 - 10:45
(25) поле выбора у вас здесь договор. Вы договор выбираете в этой процедуре. Какой нахрен поле выбора Владелец?
   dka80
 
27 - 11.03.20 - 10:47
(26) что ты докапался до Элементы.Владелец? Это вообще кому вернется результат выбора. У него форма без отбора открывается.
   KoderZ
 
28 - 11.03.20 - 10:54
(26) (27) сходи по ссылке  http://1s-portal.ru/index.php/stati/configuration/3-form/87-kak-ustanovit-otbor-v-otkryvaemoj-forme.html

и не задавай вопросов .
   KoderZ
 
29 - 11.03.20 - 10:55
(26) переделай мой код . и напиши куда его вставить
   KoderZ
 
30 - 11.03.20 - 10:59
не работает

&НаКлиенте
Процедура ВладелецНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
       СтандартнаяОбработка= Ложь;
     ЗначениеОтбора = Новый Структура("Договор", Договор);
    ПараметрыВыбора = Новый Структура("Отбор", ЗначениеОтбора);

    ОткрытьФорму("Справочник.ДоговорыКонтрагентов.ФормаВыбора",ПараметрыВыбора, Договор);// здесь передан Элемент, чтобы выбранное значение попало в поле

     
//

 
 
КонецПроцедуры
 
 Рекламное место пустует
   KoderZ
 
31 - 11.03.20 - 11:08
кто подскажет .что не так?

&НаКлиенте
Процедура ДоговорНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
      ЗначениеОтбора = Новый Структура("Владелец", Элементы.Контрагент);
    ПараметрыВыбора = Новый Структура("Отбор", ЗначениеОтбора);

    ОткрытьФорму("Справочник.ДоговорыКонтрагентов.ФормаВыбора",ПараметрыВыбора, Элемент); 
КонецПроцедуры


{Обработка.РабочееМестоЛизинг.Форма.ФормаЭлемента.Форма(5129)}: Ошибка при установке значения атрибута контекста (ПараметрыВыбора)
    ПараметрыВыбора = Новый Структура("Отбор", ЗначениеОтбора);
по причине:
Несоответствие типов
Несоответствие типов
   dka80
 
32 - 11.03.20 - 11:10
ПараметрыВыбора - предопределенная переменная
Напиши 
ПараметрыВыбора2 = Новый Структура("Отбор", ЗначениеОтбора);

    ОткрытьФорму("Справочник.ДоговорыКонтрагентов.ФормаВыбора",ПараметрыВыбора2, Элемент);
   KoderZ
 
59 - 11.03.20 - 12:51
Так работает . мож кому то пригодится ,  народ тут малограмотный и хамливый . неприятно . модеры не банят уже таких ,очень странно


&НаКлиенте
Процедура ДоговорНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
     СтандартнаяОбработка=Ложь;

Если ЗначениеЗаполнено(Объект.Владелец) Тогда 

П = Новый Структура("Владелец", Объект.Владелец);
тФорма = ПолучитьФорму("Справочник.ДоговорыКонтрагентов.Форма.ФормаВыбора", Новый Структура("Отбор",П)); 

тФорма.Открыть();
иначе 
тФорма = ПолучитьФорму("Справочник.ДоговорыКонтрагентов.Форма.ФормаВыбора"); 
тФорма.Открыть();
КонецЕслИ;
  
КонецПроцедуры


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.