Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

сохранение настроек в файл

сохранение настроек в файл
Я
   ALEX7519
 
10.03.20 - 12:04
Ситуация : 1с БП 3.0 есть внешняя обработка, в ней есть табличная часть  (Способы)
Добавил на форму пару кнопок для сохранения, зарузки значений которые туда набьют

вроде работает. А можно эти данные еще и в файл куда-нибудь сохранять (и загружать соответственно) - на случай если бухи похерят эти настройки

&НаСервере
Процедура СохранитьННаСервере()
    КлючНастроек = "ЗагрузкаЗарплатыИзЗУП";    
    Настройки = Новый Соответствие;
    
    Настройки.Вставить("Способы", Объект.Способы.Выгрузить());
    
    ОбщегоНазначения.ХранилищеОбщихНастроекСохранить("ЗагрузкаЗарплатыИзЗУП_Водоканал83", КлючНастроек, Настройки);
    
КонецПроцедуры

&НаКлиенте
Процедура СохранитьН(Команда)
    СохранитьННаСервере();
КонецПроцедуры

&НаСервере
Процедура ЗагрузитьННаСервере()
    КлючНастроек = "ЗагрузкаЗарплатыИзЗУП";    
    ЗначениеНастроек = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("ЗагрузкаЗарплатыИзЗУП", КлючНастроек);    
    Если ТипЗнч(ЗначениеНастроек) = Тип("Соответствие") Тогда
        Объект.Способы.Загрузить(ЗначениеНастроек.Получить("Способы"));    
    КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ЗагрузитьН(Команда)
    ЗагрузитьННаСервере();
КонецПроцедуры
   Галахад
 
1 - 10.03.20 - 12:14
Храни там же:
ОбщегоНазначения.ХранилищеОбщихНастроекСохранить("ЗагрузкаЗарплатыИзЗУП_Водоканал83_Бэкап", КлючНастроек + ТекущаяДата(), Настройки);
   ALEX7519
 
2 - 10.03.20 - 12:47
(1) и потом если сломают востанавливать на нужную дату ? ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("ЗагрузкаЗарплатыИзЗУП", КлючНастроек + ДАТА);    

а хранилище не может похерится если копию базы сделать или еще как-нито ?
   mikecool
 
3 - 10.03.20 - 12:56
настройки сериализовать и в хмл файл записать
обратно - прочитал и десериализовал
   Галахад
 
4 - 10.03.20 - 12:57
(2) Ну типа того.

Все может быть. Но хранить в базе, в любом случае надежнее чем в файлах. Если базу бэкапить, конечно.
   ALEX7519
 
5 - 10.03.20 - 13:29
(3) хм а это как ? :)
(4) я там не на постоянке хз что они там без меня творят - мне проще себе в файл сохранить до темных времен )

Список тем форума
Рекламное место пустует  Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.