Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как распечатать выделенные док-ты из формы списка сразу на принтер

Как распечатать выделенные док-ты из формы списка сразу на принтер
Я
   Arland
 
08.03.20 - 12:22
Добрый день! Девчат с Праздником!!!!

Помогите распечатать выделенные документы "Реализация товаров и услуг" из формы списка документов без предварительного просмотра сразу на принтер с количеством копий по 2 экземпляра.

Написал в модуле Формы списка Процедуру.

Процедура ДействиеГрупповаяПечать(Кнопка)

ВыделенныеСтроки = ЭлементыФормы.Список.ВыделенныеСтроки;

Если ВыделенныеСтроки.Количество() = 0 Тогда

Возврат;

КонецЕсли;

Массив = Новый Массив;

Для каждого ВыделеннаяСтрока Из ВыделенныеСтроки Цикл

УниверсальныеМеханизмы.НапечататьДокументИзФормыСписка(ВыделеннаяСтрока.Ссылка.ПолучитьОбъект());

КонецЦикла;

КонецПроцедуры

Если так, то открывается предварительный просмотра каждого документа.

А, надо, чтобы автоматом на принтер.
   JeHer
 
1 - 08.03.20 - 12:33
(0) это что? УТ 10.3?
   Garykom
 
2 - 08.03.20 - 12:35
(0) Это очень просто! Достаточно взять N-ю сумму денег и нанять "Программиста 1С".
   Garykom
 
3 - 08.03.20 - 12:37
УниверсальныеМеханизмы.НапечататьДокументИзФормыСписка("а тут сколько параметров возможно?")
   Arland
 
4 - 08.03.20 - 12:38
(1) Да УТ 10.3
   Arland
 
5 - 08.03.20 - 12:40
(3) Вроде 3 наверное)
   Arland
 
6 - 08.03.20 - 12:41
Ребят подтолкните к правильному решению задачи
   ДенисЧ
 
7 - 08.03.20 - 12:41
НаПринтер = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(ПараметрыСеанса.ТекущийПользователь, "ПечатьДокументовБезПредварительногоПросмотра") = Истина;

Это из вызываемой процедуры.

Какой делать вывод будем?
   Garykom
 
8 - 08.03.20 - 12:44
(7) А есть УправлениеПользователями.УстановитьЗначениеПоУмолчанию ?
   Arland
 
9 - 08.03.20 - 12:45
(7) Не знаю!) И какой вывод?
   Arland
 
10 - 08.03.20 - 12:45
(8) сча посмотрю
   Garykom
 
11 - 08.03.20 - 12:47
У тебя два варианта или поставить это ПечатьДокументовБезПредварительногоПросмотра или другая функция УниверсальныеМеханизмы.НапечататьДокумент... и там три параметра есть и третий Истина
   Arland
 
12 - 08.03.20 - 12:59
(11) {ОбщийМодуль.УниверсальныеМеханизмы.Модуль(1034)}: Обращение к процедуре объекта как к функции (УстановитьЗначениеПоУмолчанию)
    НаПринтер = УправлениеПользователями.УстановитьЗначениеПоУмолчанию(ПараметрыСеанса.ТекущийПользователь, "ПечатьДокументовБезПредварительногоПросмотра") = Истина;
   ДенисЧ
 
13 - 08.03.20 - 13:00
:wall:
(12) Это очень сложная для исправления ошибка... Но маленькая подсказка есть в (2)
   Arland
 
14 - 08.03.20 - 13:02
(13) Денис помоги пож.
   ДенисЧ
 
15 - 08.03.20 - 13:05
(14) Я тебе дал все пояснения. Программисту, который в 1с больше одного месяца возится - их достаточно. Если не понятно, то, может, 1с, и вообще программирование, это не твоё?
   Arland
 
16 - 08.03.20 - 13:15
(13) Поставил галочку в настройках пользователя "Печать документов без предварительного просмотра", все равно вылазит окно предварительного просмотра
   Arland
 
17 - 08.03.20 - 13:18
(11) УниверсальныеМеханизмы.НапечататьДокументИзФормыСписка(ВыделеннаяСтрока.Ссылка.ПолучитьОбъект(),2, Истина);

{Документ.РеализацияТоваровУслуг.Форма.ФормаСписка.Форма(236)}: Слишком много фактических параметров
        УниверсальныеМеханизмы.НапечататьДокументИзФормыСписка(ВыделеннаяСтрока.Ссылка.ПолучитьОбъект(),2, Истина);
   Garykom
 
18 - 08.03.20 - 13:20
"или другая функция"
   ДенисЧ
 
19 - 08.03.20 - 13:27
(16) А пользователя перезапустил? А отладчиком прошёл?
   Arland
 
20 - 08.03.20 - 14:01
(19) Перезапусти, отладка {(1,1)}: Переменная не определена (НапечататьДокументИзФормыСписка)
   Arland
 
21 - 08.03.20 - 14:03
(20) при этом выводит предварительный просмотр выделенных документов из списка
   Arland
 
22 - 08.03.20 - 14:57
(11) (19) Ребят Спасибо огромное!!! Просто я не учел, что я печатаю внешнюю печатную форму!) Спасибо еще раз!
   ДенисЧ
 
23 - 08.03.20 - 15:34
(22) F rfr 'nj cdzpfyj& J_j
   ДенисЧ
 
24 - 08.03.20 - 15:34
Блин...
Как это связано?


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.