Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Какая то аномалия, новый код отладчик не видит

Какая то аномалия, новый код отладчик не видит
Я
   Rassvetniy
 
05.03.20 - 14:40
Добрый день, собственно суть в названии, есть изменения в коде но отладчик ходит и выполняет что то невидимое на входе написал
а=5;
        сообщить(111);
    массивСтрок = новый массив; все это пропускает но сообщить кстати выполняет это у меня уже какое то помутнение, чудо от расширений или еще что то? к папке где база лежит в виндовзе доступа нету может это как то влияет, чушь какая то никогда раньше с таким не сталкивался
   ДенисЧ
 
1 - 05.03.20 - 14:40
кеша
   Rassvetniy
 
2 - 05.03.20 - 14:44
(1) кеш чистил путем пересоздания базы в стартере, у меня 2 варианта или расширения чудят или мне таких чудо прав выделили сисадмины что там сумасшедствие
   rphosts
 
3 - 05.03.20 - 14:52
Хранилище?
   Rassvetniy
 
4 - 05.03.20 - 14:54
(3) нет там хранилища, унф 3.15 платформа, файловая
   rphosts
 
5 - 05.03.20 - 14:56
Тии со всеми галочками, выгрузка-загрузка, но на копии!!!
   Rassvetniy
 
6 - 05.03.20 - 14:57
(5) что значит выгрузка загрузка и на копии?
   1Сергей
 
7 - 05.03.20 - 15:01
F5 нажимал? :)
   mikecool
 
8 - 05.03.20 - 15:08
а Ф7 нажимал?
   Rassvetniy
 
9 - 05.03.20 - 15:40
ф5 и ф7 ну не осел же я )
   Rassvetniy
 
10 - 05.03.20 - 15:41
перую версию процедуры прогр подхватила, сделал изменения смотрю отладчиком отладчик по старой версии ходит, добавляешь сообщить - работает, убираешь тоже видит изменение но отладчик на строчку сообщить на становится...
   RomaH
 
11 - 05.03.20 - 15:42
динамическое обновление?
   RomaH
 
12 - 05.03.20 - 15:44
в 14 или 15 версии было что-то похожее
сначала все хорошо, а потом - старый кот

наблюдал именно при дин обновлении - но может мне повезло

сейчас на 1С:Предприятие 8.3 (8.3.15.1565) такого не наблюдаю
   Rassvetniy
 
13 - 05.03.20 - 15:44
(11) обычное, тестовая база, уже несколько раз базу пересоздавал
   Rassvetniy
 
14 - 05.03.20 - 15:44
(12) а расширения там были? что то у меня на них подозрения
   RomaH
 
15 - 05.03.20 - 15:45
расширения - зло
   Rassvetniy
 
16 - 05.03.20 - 15:46
(15) тут платформа 3.5.1700
   RomaH
 
17 - 05.03.20 - 15:48
... расширения на такой древности? ... да вы, батенька, тот еще ... адреналиновый маньяк
   Rassvetniy
 
18 - 05.03.20 - 15:50
(17) пардон 3.15.1700
   Rassvetniy
 
19 - 05.03.20 - 16:06
в клиентских процедурах отладчик ведет себя правильно а в серверных черт знает как, в старых серверных поведение отладчика корректное
   Marik1274
 
20 - 05.03.20 - 16:11
Была недавно такая проблема. Помогал перезапуск службы сервера 1с.
В какой-то момент это перестало помогать, помогла только перезагрузка сервера.
   Rassvetniy
 
21 - 05.03.20 - 16:20
(20) тут файловая база
   Rassvetniy
 
22 - 05.03.20 - 17:00
пришел к вывод что дело в расширениях... тоже на основной конфигурации все показывает работает отладчик правильно, в итоге вопрос как победить глюк что в расширениях формы в серверных процедурах отладчик не по коду ходит а ходит неведомо где
   Rassvetniy
 
23 - 05.03.20 - 17:19
при чем в общий модуль серверный в расширение добавленый заходит нормально а если серверная процедура добавлена на форме то чушь


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.