Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УПП. Обязательное указание Характеристики номенклатуры.

УПП. Обязательное указание Характеристики номенклатуры.
Я
   withoutname
 
05.03.20 - 12:30
Собственно сабж ) И еще проверка дублей характеристик
Быстрым осмотром не нашел.
Имеется ли?
Если нет, как лучше реализовать?
   withoutname
 
1 - 05.03.20 - 13:51
Справка и код показывают что дублирование контролируется...
   withoutname
 
2 - 05.03.20 - 15:31
Всё приходится делать самому )

Создал регистр сведений с 1м Измерение Свойства

Перед типовой проверкой на Аналогичные характеристики проверяю заполненность свойств

Запрос = Новый Запрос;
    Запрос.Текст=
    "ВЫБРАТЬ
    |    юскОбязательныеХарактеристики.Свойство
    |ИЗ
    |    РегистрСведений.юскОбязательныеХарактеристики КАК юскОбязательныеХарактеристики";
    ТЗОбязательныеСвойства = Запрос.Выполнить().Выгрузить();
    
    Для каждого Строка Из ОбработкаОбъектЗначенияСвойств.СвойстваИЗначения Цикл
        Если ТЗОбязательныеСвойства.Найти(Строка.Свойство, "Свойство") = Неопределено Тогда
            Продолжить;
        КонецЕсли;
        Если не ЗначениеЗаполнено(Строка.Значение) Тогда
            
            Сообщить("Свойство """ + Строка.Свойство + """ обязательно к заполнению!", СтатусСообщения.ОченьВажное);
            Отказ = Истина;
            
        КонецЕсли;
    КонецЦикла;
    Если Отказ Тогда
        Предупреждение("Некорректное заполнение, прочитайте Служебные сообщения!",, "Ошибка");
        Возврат;
    КонецЕсли;

   Джинн
 
3 - 05.03.20 - 15:37
Хорошо. Возьмите с полки пирожок.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.