Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Нов. ПланОбменаПоСкладу, делаю по аналогии "ПоОрганизации", ошибка ПараметрыСеанса

Нов. ПланОбменаПоСкладу, делаю по аналогии "ПоОрганизации", ошибка ПараметрыСеанса
Я
   SkillUp
 
05.03.20 - 12:18
Здравствуйте, делаю новый план обмена по складу (РИБ). Делаю по аналогии "ПоОрганизации". Столкнулся с такой проблемой. Связанной с параметрами ПараметрыСеанса.

Вот код из типовой:

Процедура ПриОтправкеДанныхПодчиненному(ЭлементДанных, ОтправкаЭлемента, СозданиеНачальногоОбраза)

    ...
    
    Если мСоотвествиеОрганизацийИУзлов = Неопределено Тогда
        
        мСоотвествиеОрганизацийИУзлов = ПроцедурыОбменаДаннымиПоОрганизации.ПолучитьСоотвествиеУзловИОрганизаций();
        
    КонецЕсли;
    
    ...
КонецПроцедуры;

Код из модуля - "ПроцедурыОбменаДаннымиПоОрганизации".

Функция ПолучитьСоотвествиеУзловИОрганизаций() Экспорт
    
    Хранилище = ПараметрыСеанса.СоответствиеОрганизацийИУзловОбменаПоОрганизации;
        
    СоотвествиеУзловИОрганизаций = Хранилище.Получить();
    
    Возврат СоотвествиеУзловИОрганизаций;
    
КонецФункции

В чем собств. проблема? У меня план обмена новый ,только идет отбор по не по организации, а по складу. В параметрах сеанса его нету. Или его надо добавить? Только не пойму как? Или как обойти эту проблему, кто знает, то "плаваю" в этой тематике...
 
 
   SkillUp
 
1 - 05.03.20 - 12:40
Надо добавить новый план обмена, в параметры сеанса. Кто знает как правильно это выполнить? В какой процедуре?
   Василий Алибабаевич
 
2 - 05.03.20 - 12:43
(1) "Надо добавить новый план обмена, в параметры сеанса."
Этто йес. ""плаваю" в этой тематике..." это еще мягко сказано. Казалось что вы плохо разбираетесь в теме. А вышло что вы вообще не имеете о ней никакого представления.
   SkillUp
 
3 - 05.03.20 - 12:57
(2) Согласен, представления нет. Подскажешь что делать? И как правильно делать?
   SkillUp
 
4 - 05.03.20 - 13:07
(2) Тфу, блин. Все, понял. Тема закрыта.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.