Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

По переключателю выбрать только нужные товары

По переключателю выбрать только нужные товары
Я
   Doroheart
 
04.03.20 - 16:29
Добрый день, столкнулся с проблемой реализации печати только ценников без действующих скидок.

В данный момент переключатель реализован так:

Процедура ПереключательПриИзменении(Элемент)
    Если Переключатель2 = 1 Тогда
        Для каждого СтрокаТовара из Товары Цикл
            СтрокаТовара.Выбран = Истина
        КонецЦикла;
    КонецЕсли;
    Если    Переключатель2 = 2 Тогда
        Для каждого СтрокаТовара из Товары Цикл
            Если    СтрокаТовара.БЗМЖ Тогда
                СтрокаТовара.Выбран = Истина
            Иначе
                СтрокаТовара.Выбран = Ложь
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;
    Если    Переключатель2 = 3 Тогда
        Для каждого СтрокаТовара из Товары Цикл
            Если СтрокаТовара.БЗМЖ = Ложь Тогда
                СтрокаТовара.Выбран = Истина
            Иначе
                СтрокаТовара.Выбран = ЛОЖЬ
            КонецЕсли;


//ПечатьТолькоДействующихСкидок
Как думаете такой запрос подойдет?

            Если Переключатель2 = 4 Тогда
                Для каждого СтрокаТовара из Товары Цикл
                    Запрос = Новый Запрос
                    Запрос.Текст =
                    "ВЫБРАТЬ ПЕРВЫЕ 100
                    | Скидки.Подразделение,
                    | Скидки.Объект
                    |ИЗ
                    |  РегистрСведений.Скидки.СрезПоследних КАК Скидки
                    |ГДЕ
                    |  Скидки.Активность = Истина
                    |И КОНЕЦПЕРИОДА(&ТекущаяДата, День) МЕЖДУ Скидки.НачалоДействия и Скидки.КонецДействия
                    |И Скидки.Действует = Истина";
                    
                        
        КонецЦикла;
    КонецЕсли;
КонецПроцедуры
   vicof
 
1 - 04.03.20 - 16:31
Нет
   Doroheart
 
2 - 04.03.20 - 16:33
(1) а как тогда лучше обозначить если товар со скидкой чтобы выделял его для печати?
   vicof
 
3 - 04.03.20 - 16:39
хз, что у тебя за конфа, в чем проблема при печати.
Я пока вижу несоответствие в условиях и в приведенном коде.
Запрос в цикле зло.
Сам запрос тоже так себе.
Кода по обозначению выбранных товаров нет.
   Doroheart
 
4 - 04.03.20 - 16:42
(3) ТКПТ Рарус, я планирую брать из списка товара который в регламенте сверять с текущими скидками и снимать выбран с тех на которые не назначены скидки.
   vicof
 
5 - 04.03.20 - 16:53
Я эту конфу ни разу не видел. Но для решения задачи, берешь те товары, которые в "регламенте", помещаешь в таблицу с отбором тех строк, которых нет в таблице скидок, а в цикле уже заполняешь ТЧ.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.