Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: QR код В 1С 7.7 (2)

v7: QR код В 1С 7.7 (2)
Я
   OnePrg
 
03.03.20 - 09:41
Продолжение темы QR код В 1С 7.7

Помогите разобраться с компонентой OcvitaBarcode. Когда выводимых символов больше некоторого порога, то QR код не выводится

http://imagizer.imageshack.com/img923/1466/DiFUuN.png

Как настроить компоненту? Как получить сообщение от компоненты с кодом возврата?
   mishaPH
 
Модератор
1 - 03.03.20 - 09:43
вы в код запихиваете всю накладную?
зачем
   Aleksey
 
2 - 03.03.20 - 09:43
вы туда главы войны и мир пишите? Учтите что потом будут проблемы с чиением, или ваше дело напечатать?
   OnePrg
 
3 - 03.03.20 - 09:52
Зачем: У заказчика такая система, что все документы, что печатает по складу за день оператор в 1С вторые копии получает МОЛ. На следующий день, когда документы в 1С закрыты для редактирования, МОЛ с оператором 1С сидят и сверяют бумажные документы с документами в 1С. Стоит задача этот процесс автоматизировать.

Вот этот текст выводится в QR код

ddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddd

а вот этот уже нет

dddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddd
   mishaPH
 
Модератор
4 - 03.03.20 - 09:54
(3) а вы знаете толк в изврате....

а не проще при выводе накладной запоминать ее состояние где-то. на накл только ссылку на нее
   mishaPH
 
Модератор
5 - 03.03.20 - 09:56
(3) ну так посчитай сколько символов он выводит. и возьми за аксиому. Далее при попытке вывести проверяй.

самое главное ну убедился что не влезет что делать собираешся? накладную не печатать в принципе и ругатся сократите?
   OnePrg
 
6 - 03.03.20 - 09:57
если не прокатит с QR кодом, то будем делать по другом

сам QR код на сколько я знаю позволяет выводить что-то около 2 тыс знаков, почему же он здесь выводит значительно меньше?
   Aleksey
 
7 - 03.03.20 - 10:11
(6) откуда фантазия о 2 тысячах?
Зависит от версии, может быть и 27 цифр максимум (с) https://creambee.ru/blog/post/qr-specification/
   Kigo_Kigo
 
8 - 03.03.20 - 10:12
(6) потому что создатели OcvitaBarcode не думали, что из 1с будут печатать код на всю страницу А4
   Aleksey
 
9 - 03.03.20 - 10:14
(3) а не проще ли при печати сохрантья ТЧ в файл, а потом нажатием одной кнопки сравнивать версию в файле и в базе? Представь какая экономия на оборудовании и людях
   Aleksey
 
10 - 03.03.20 - 10:16
У меня так был организован отчет по вычеркам. Т.е. на склад печатали бумажку, которая сохранялась в файле, далее склад что то не нашел и оператор удалил эту позицию из накладной. Потом отчет сравнивал то что было и то что стало - и готово отчет по вычеркам.
   victuan1
 
11 - 03.03.20 - 10:19
(0) А если распечатать через formex.dll?
   OnePrg
 
12 - 03.03.20 - 10:29
(11) дай пожалуйста пример

вот та обработка, которую я взял за пример http://mzxxe5ln.nfxgm33torqxe5booj2q.nblu.ru/bitrix/components/bitrix/forum.interface/show_file.php?fid=388754&action=download
   NorthWind
 
13 - 03.03.20 - 10:32
(3) я не советовал бы использовать ШК для хранения больших объемов инфы. Недоследят за картриджем, начнет полосить - и вся эта система ляжет. Лучше всего использовать 1D код, который позволит тупо считывать метку-ссылку,
по которой уже искать данные в других источниках. И обязательно предусмотреть ручной ввод метки на случай если чего-то не считается.
   NorthWind
 
14 - 03.03.20 - 10:34
складская специфика - она такая - там чем проще и надежнее, тем лучше.
   victuan1
 
15 - 03.03.20 - 11:25
(12) Кладешь в макет объект Картинка, прописываешь ей формулу:
[url=https://ibb.co/C8gwd2S][img]https://i.ibb.co/C8gwd2S/image.png[/img][/url]

//------------------------------------------------------------------------------

Процедура ВыводШтрихкодаВТаблицу(Картинка,ТипЧислом,ТекстШтрихкода)

 Сервис.НарисоватьШтрихкод(Картинка,ТипЧислом,ТекстШтрихкода,0);
 Картинка.РежимРисования(3);

КонецПроцедуры//ВыводШтрихкодаВТаблицу


//------------------------------------------------------------------------------

Процедура Сформировать()
  Т = СоздатьОбъект("Таблица");
   Попытка
    Сервис = СоздатьОбъект("Сервис");
   Исключение
    сообщить("Неудачная попытка создания объекта Сервис. Возможно, нужно установить более новую версию formex.dll");
    Возврат
   КонецПопытки; 
  стрВерсия = ""; нВерсия = Сервис.Версия(стрВерсия);
  Если нВерсия < 33555843 Тогда//проверяем чтобы версия была не не ниже 2.0.5.131 иначе напечатанный QR-код будет нечитаем сканером

   сообщить("Установлена версия Formex.dll "+стрВерсия+". Для печати QR-кода версия должна быть не ниже 2.0.5.131.","!!");
   Возврат
  КонецЕсли;

..
     Т.ВывестиСекцию("Строка");
..

КонецПроцедуры
   victuan1
 
16 - 03.03.20 - 11:25
   OnePrg
 
17 - 03.03.20 - 14:30
Всем спасибо за участие.
Пока решил вопрос тем, что убрал из QR кода наименование номенклатуры, оставил только код. Теперь в QR код попадают только цифры и точки с запятыми. В таком режиме QR код легко вмещает информацию из документа в 10 строк (более не проверял). Этого пока достаточно.
   АЛьФ
 
18 - 03.03.20 - 14:55
Если я правильно понимаю, то это проверка неизменности накладной (непонятно почему нельзя запретить редактировать распечатанные документы, но пусть). Для такой проверки достаточно сформировать хэш типа MD5, его и печатать.
   arsik
 
19 - 03.03.20 - 15:00
(18) Такая проверка не покажет что изменилось. Придется снова руками по накладной пробегать. Предлагали уже историю хранить - не хотят :)
   mishaPH
 
Модератор
20 - 03.03.20 - 15:00
(17) а вы туду и наиманование пихали???? ну вы даете.. а если наим поменяли весь контроль уже распечатанных идет лесом?
   АЛьФ
 
21 - 03.03.20 - 15:50
2(19) Так проще и быстрей сначала выявить измененные, а потом уже найти изменения.
   user100000
 
22 - 08.03.20 - 01:36
размер квадратика увеличьте


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.